Blank page on shared hoster

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
redbird
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 18 Mar 2013, 15:33

Blank page on shared hoster

Postby redbird » 18 Mar 2013, 15:57

Hey,

I'm currently evaluating to use TT-RSS as a possible better replacement for Google Reader and installed it on a shared hoster. After having modified the config.php, there is only a blank page when requesting the index.php. I guess the restricted runtime environment is the source of evil and failure. However I'm curious why there is no error report and which php settings might prevent the use of TT-RSS. Therefore I've made this pretty picture: Image.

Thank you for your help.

Cwiiis
Bear Rating Trainee
Bear Rating Trainee
Posts: 14
Joined: 15 Mar 2013, 14:37

Re: Blank page on shared hoster

Postby Cwiiis » 18 Mar 2013, 16:49

I had the same issue - you should check your server logs, as the error will likely be output there. For me, the error was that I didn't have php-mbstring installed, which is a requirement.

Joschasa
Bear Rating Trainee
Bear Rating Trainee
Posts: 34
Joined: 03 May 2010, 11:58

Re: Blank page on shared hoster

Postby Joschasa » 18 Mar 2013, 18:04

If the error.log points out, tt-rss cant find the sessions.php, most likely the apache config set a value for inclue_path via set_admin_value.
tt-rss tries to append (at least) the includes/ directory to include_path.
Workaround? I don't know. If you cant reach the admin and/or edit the global apache config, the rewrite of all includes in tt-rss is the only solution that comes to my mind.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests