Page 2 of 3

Re: [git] Mobile site not working?

Posted: 24 Mar 2013, 02:34
by miqrogroove
j0nson, your mobile app doesn't work for me either. It fixes the 404 error and I can log in, but then all it says is Fresh Feed on one line and then No New Articles on the next line. I can't see any of my feeds or articles.

This is all sketchy as hell.

p.s. PHP Warning: Invalid argument supplied for foreach() in /mobile/index.php on line 398

Re: [git] Mobile site not working?

Posted: 24 Mar 2013, 03:13
by j0nson
I can't decide whether I should be a dick because you're being a dick, or be nice and help you out.

Which would you rather?

Re: [git] Mobile site not working?

Posted: 24 Mar 2013, 21:52
by feader
On my tablet, the standard look works pretty well. TTRSS wanted to take me to /mobile, so I had to remove the lines 34-42 in index.php. Since there are well working alternatives for phones: Will the whole "mobile check" thing be removed in future releases?

Re: [git] Mobile site not working?

Posted: 24 Mar 2013, 23:05
by UncleAndy
It is reason for keep on old version. :(
Very bad idea - remove mobile version from main distro.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 15:21
by lyallp
I was quite impressed by a brief look at the mobile version on my iPhone with 1.7.4. I did not use it, but it was nice to know something was there, should I want to peruse my feeds on my iPhone.

I was quite suprised to find the mobile ability was gone in 1.7.5, even more so that it was not only gone but broken.

I am unsure as to why this was removed, particularly since I can't seem to find an obvious app in iTunes and the change log indicated that apps were the way to go.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:02
by shabble
lyallp wrote:I am unsure as to why this was removed,

I get the impression that the codebase used for the mobile version was (3rd party and) outdated.

A quick alternative I used was
  • install ttrs-mobile (described here, download from here ('zip' link top left) ) - it could probably even go in your now-empty mobile directory.
  • Enabled API for my user
  • went to new URL (probably not be needed if you stuff it in the mobile directory)

Found it relatively painless myself, but I think some above may have had problems...?

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:07
by xtaz
Change-logs are there for a reason: http://tt-rss.org/redmine/versions/87

Remove deprecated mobile/ in favor of mobile client by Matthieu Boinet


In other words it's specifically telling you to use the ttrss-mobile that you just linked to.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:20
by shabble
xtaz wrote:Change-logs are there for a reason: http://tt-rss.org/redmine/versions/87

Remove deprecated mobile/ in favor of mobile client by Matthieu Boinet


In other words it's specifically telling you to use the ttrss-mobile that you just linked to.


You presume, of course, that when I started this thread that I was upgrading from 1.7.4 to 1.7.5, when the subject of the whole thread indicates quite the opposite.

Thank you for your concern however.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:39
by blainemono
methinks that lady dost presumst too much

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:41
by fox
I don't want to be a bother or anything but ignoring both commit messages and release notes while following trunk is a sure way to hilarity town.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:42
by blainemono
nah, I'm doing it and I'm ok

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:45
by fox
That's because you're a special boy. Not everyone is.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:46
by miqrogroove
In case anyone cares, I'm staying at 1.7.4 so that I can use Opera Mini 4.4, which is the latest browser version offered for my phone.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:47
by shabble
fox wrote:.. but ignoring [...] commit messages ...


I know - that one was my fault. Or rather I skipped over it without realising the impact, and promptly forgot about it.

Re: [git] Mobile site not working?

Posted: 26 Mar 2013, 16:47
by fox
It would be quite easy to dig out mobile/ and convert it into a plugin or something for people who can't let go.