Page 1 of 1

Updating

Posted: 27 Mar 2013, 15:46
by vbmark
Hello,

I see that there is a new version and I would like to do an update. I see that there is a plugin named, "updater - Updates tt-rss installation to latest version." But the button is disabled. Is there a way to get the app to "self update" or do I just need to download and reinstall?

Also, Tiny Tiny RSS is awesome!

Thanks!

Re: Updating

Posted: 27 Mar 2013, 16:03
by dxbi
It's in the docs.

Re: Updating

Posted: 27 Mar 2013, 16:24
by vbmark
Ok, I followed the documentation and added it to the config.php and I see that the checkbox is now checked -- cool :D

I click update but just get this...

Image

Re: Updating

Posted: 27 Mar 2013, 16:34
by fox
This was I think fixed in 1.7.5. :)

Re: Updating

Posted: 27 Mar 2013, 16:55
by vbmark
LOL, ok, cool.

Re: Updating

Posted: 27 Mar 2013, 21:53
by kraleksandr
fox wrote:This was I think fixed in 1.7.5. :)

U said that if I want use automatic updater, I must update to 1.7.5 manually, right?

Re: Updating

Posted: 27 Mar 2013, 22:07
by erikbennett
You should be able to look at the following:

https://github.com/gothfox/Tiny-Tiny-RS ... 1509e5e358

I made the change on my 1.7.4 install and was able to update to 1.7.5 using the updater.

Re: Updating

Posted: 27 Mar 2013, 22:55
by Joschasa
If you have shell access to your tt-rss instance, you can run "./update.php --update_self" to use the updater.

Re: Updating

Posted: 28 Mar 2013, 22:42
by lawiedc
That fix was enough for my upgrade to work too.

It needed me to copy SMTP_PORT line in from config.php-dist - and the message was 100% clear so no difficulty following the instruction.

Edit:
After install I had to
- refresh my custom css
- update my cron job update to use --feeds
- copy back from backup my extra plugins

Re: Updating

Posted: 29 Mar 2013, 16:34
by vbmark
I get the below errors now after I tried updating manually and also after a second try by fixing the ini.php file and running auto update.

Code: Select all

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/blah/public_html/tinytinyrss/index.php on line 98

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /home/blah/public_html/tinytinyrss/index.php on line 98


Any suggestions?

Re: Updating

Posted: 29 Mar 2013, 18:54
by vbmark
Here is how I fixed this:

1) Create a file named .htaccess and add the following lines:

Code: Select all

# Use PHP 5.3
AddType application/x-httpd-php53 .php


2) This step may or may not be necessary for you (it was for me):

Open config.php and add the following lines in the section named, "Email and digest settings":

Code: Select all

define('SMTP_PORT','');
// SMTP port to sent outgoing mail. Default is 25.


The errors all went away, I was able to log in, then the app updated the database.

Now all is well!