Hostgator

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
mbcladwell
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 01 Apr 2013, 13:47

Hostgator

Postby mbcladwell » 01 Apr 2013, 14:00

Having difficulty getting updates to work with Hostgator. Have learned the following:
php 5.3 executable: /opt/php53/bin/php
DB_HOST: <username>_<db_name>@localhost e.g. user_ttrss@localhost
cron command: /opt/php53/bin/php update.php --feeds >/dev/null 2>&1

Hostgator support indicates that the cron job contains the path to all files, so I do not need the cd command to navigate to the rss directory.
(I have tried with the cd command, that does not work either)
The cron command is executing.
Simple update works, suggesting the database is properly configured. The cron does not seem to update though.
Any assistance appreciated.
Thanks
Mortimer

User avatar
Se9n
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 01 Apr 2013, 16:37
Location: Reno, NV USA
Contact:

Re: Hostgator

Postby Se9n » 01 Apr 2013, 16:44


wxyz
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 01 Apr 2013, 18:50

Re: Hostgator

Postby wxyz » 01 Apr 2013, 18:55

This is the cron job at hostgator I use.

cd /home/ACCOUNTNAME/public_html/TTRSSFOLDER && /opt/php53/bin/php -d register_argc_argv=On -f /home/ACCOUNTNAME/public_html/TTRSSFOLDER/update.php -- --feeds >/dev/null 2>&1

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Hostgator

Postby fox » 01 Apr 2013, 19:00

You really don't need to cd, update.php does chdir() into tt-rss directory. That part of the wiki was woefully obsolete.

wxyz
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 01 Apr 2013, 18:50

Re: Hostgator

Postby wxyz » 01 Apr 2013, 19:47

Last edited by wxyz on 01 Apr 2013, 19:49, edited 1 time in total.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Hostgator

Postby fox » 01 Apr 2013, 19:48

The recommended way from now on should be just --quiet instead of >/dev/null. In 1.7.5 it generates some unnecessary output, but in 1.7.6 it should be fine. This way you will get the email if something bad happens.

I've updated the wiki, etc.

User avatar
erikbennett
Bear Rating Trainee
Bear Rating Trainee
Posts: 20
Joined: 17 Mar 2013, 03:08
Location: Seattle, WA

Re: Hostgator

Postby erikbennett » 01 Apr 2013, 20:31

I also am a hostgator user, Mortimer, and here's my CRON job:

cd /home/ACCOUNTNAME/public_html/tt-rss && /opt/php53/bin/php /home/ACCOUNTNAME/public_html/tt-rss/update.php --feeds

and everything works for me.

I think what may be tying you up, Mortimer, is that you're not fully calling the update.php in yours. Instead of just putting "update.php" you need to fully qualify it, like so "/home/ACCOUNTNAME/public_html/tt-rss/update.php" as long as that's the true path to your tt-rss install folder.

Just out of curiosity to wxyz, you put this section in "-d register_argc_argv=On -f." What for?

HTH

wxyz
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 01 Apr 2013, 18:50

Re: Hostgator

Postby wxyz » 01 Apr 2013, 21:00

erikbennett - I initially was having problems getting the cron to run correctly. In researching the issue, when I found the post that finally worked, it had it in there so I included it. I haven't had a chance yet to research it to find out if it is really needed. But based on your comment, I'm assuming I don't need it either. So I'll be updating my cron entry to remove that, along with the --quiet option at some point.

User avatar
erikbennett
Bear Rating Trainee
Bear Rating Trainee
Posts: 20
Joined: 17 Mar 2013, 03:08
Location: Seattle, WA

Re: Hostgator

Postby erikbennett » 01 Apr 2013, 21:05

Thanks for the reply. :D

BTW, I've paired my CRON down to the following: "/opt/php53/bin/php /home/ACCOUNTNAME/public_html/tt-rss/update.php --feeds --quiet" and it's working perfectly (except for the known "extra html" issue with 1.7.5, but I know that's being fixed with 1.7.6).

mbcladwell
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 01 Apr 2013, 13:47

Re: Hostgator

Postby mbcladwell » 02 Apr 2013, 01:11

Thanks for all the suggestions.
I now have my cron set for every 30 min with: /opt/php53/bin/php /home/mbcladwell/public_html/rss/update.php --feeds
Without --quiet I expect emails, but not getting any, no updates.
If I select a feed in the interface and press "update" button, feeds are delivered, marked as read when scrolled by etc.
At one point interface complained that it couldn't find the database mbcladwell_ttrss@localhost. Seems like "localhost" is the correct setting for 'DB_HOST'? (localhost is what is working with manual update).
Other parameters I may be overlooking?
Thanks
Mortimer

User avatar
erikbennett
Bear Rating Trainee
Bear Rating Trainee
Posts: 20
Joined: 17 Mar 2013, 03:08
Location: Seattle, WA

Re: Hostgator

Postby erikbennett » 02 Apr 2013, 01:17

Two things you're saying make me think the problem is your version vs what's in the wiki for the current versions. What version are you running? I believe the "--feeds" notation came about at a similar time as the loss of the "Update" button.
The most current version is 1.7.5
The best way to test it would be to change the "--feeds" to "/feeds" which I believe is the old way of calling it... maybe "-feeds"? I don't exactly remember.

mbcladwell
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 01 Apr 2013, 13:47

Re: Hostgator

Postby mbcladwell » 02 Apr 2013, 02:26

Thanks erikbennett! I have v1.7.4. I changed cron from --feeds to -feeds and that seems to be working.
Mortimer


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests