[1.7.6] Updater requires CURL

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
jonb
Bear Rating Trainee
Bear Rating Trainee
Posts: 19
Joined: 28 Mar 2013, 00:38

Re: [1.7.6] Updater requires CURL

Postby jonb » 04 Apr 2013, 00:24

I changed the && to || but am still seeing the error:

Code: Select all

Checking for tar...
Could not run tar executable (RC=1).


Any ideas?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [1.7.6] Updater requires CURL

Postby fox » 04 Apr 2013, 00:26

Could be this: https://github.com/gothfox/Tiny-Tiny-RS ... 04b42ccefa

Unless you try to run it on windows or something.

jonb
Bear Rating Trainee
Bear Rating Trainee
Posts: 19
Joined: 28 Mar 2013, 00:38

Re: [1.7.6] Updater requires CURL

Postby jonb » 04 Apr 2013, 06:21

Thanks. That worked and the update ran. However, it didn't save my cgi-bin directory and .htaccess file. I needed to copy them over from the backed-up version. I need those to remain in order to run PHP 5.3 on my shared server. Perhaps you can have these remain in place for future updates?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [1.7.6] Updater requires CURL

Postby fox » 04 Apr 2013, 08:47

The updater only copies tt-rss stuff, it notifies you to copy any other customized data you might have. Trying to guess what might be useful or not is not worth the trouble, I think.

jonb
Bear Rating Trainee
Bear Rating Trainee
Posts: 19
Joined: 28 Mar 2013, 00:38

Re: [1.7.6] Updater requires CURL

Postby jonb » 04 Apr 2013, 18:58

What if there was the option to leave in place anything that wasn't a part of the previous ttRSS distribution?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [1.7.6] Updater requires CURL

Postby fox » 04 Apr 2013, 19:02

What if there was a pony with a pizza dispenser.

What if we wouldn't increase updater complexity significantly because people are inattentive and refuse to read.

So many questions, so little time.

User avatar
idoxlr8
Bear Rating Trainee
Bear Rating Trainee
Posts: 46
Joined: 25 Mar 2013, 20:04
Location: Texas, USA
Contact:

Re: [1.7.6] Updater requires CURL

Postby idoxlr8 » 05 Apr 2013, 00:48

fox wrote:What if there was a pony with a pizza dispenser.


LMAO... to funny...

jonb
Bear Rating Trainee
Bear Rating Trainee
Posts: 19
Joined: 28 Mar 2013, 00:38

Re: [1.7.6] Updater requires CURL

Postby jonb » 05 Apr 2013, 01:49

What if we wouldn't increase updater complexity significantly because people are inattentive and refuse to read.


It's not a matter of refusing to read; I knew what to do to fix the problem; I just don't want to do it every time I update. I guess the real answer, in my case, is that installing to the root directory of the subdomain was a bad idea.

But then, I think a pony with a pizza dispenser is also an excellent idea.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [1.7.6] Updater requires CURL

Postby fox » 05 Apr 2013, 08:03

That's basically the only way I'm seeing to make updating sufficiently reliable without being overly complex. Parent required to be writable is mentioned by both the updater and installation guide.

Nobody is stopping you or anyone else from writing a better updater plugin btw. With blackjack and binary diffs. :)

User avatar
sancho1234
Bear Rating Trainee
Bear Rating Trainee
Posts: 44
Joined: 30 Mar 2013, 04:19
Location: Hungary
Contact:

Re: [1.7.6] Updater requires CURL

Postby sancho1234 » 06 May 2013, 14:37

I have "Error while extracting tarball (RC=2)." error message also. I can't upgrade the 1.7.5 to 1.7.8 version.

The php5-curl installed. The Lighttpd service restarted (I don't use Apache).

How can I go on? Can anyone help with this? Thank you for your help!

cqrt
Bear Rating Disaster
Bear Rating Disaster
Posts: 70
Joined: 05 Apr 2013, 00:37

Re: [1.7.6] Updater requires CURL

Postby cqrt » 06 May 2013, 20:14

This has been discussed before. You need to search the forums.

viewtopic.php?f=1&t=1717&p=8401&hilit=Error+while+extracting+tarball#p9029

User avatar
sancho1234
Bear Rating Trainee
Bear Rating Trainee
Posts: 44
Joined: 30 Mar 2013, 04:19
Location: Hungary
Contact:

Re: [1.7.6] Updater requires CURL

Postby sancho1234 » 07 May 2013, 11:55

cqrt wrote:This has been discussed before. You need to search the forums.

viewtopic.php?f=1&t=1717&p=8401&hilit=Error+while+extracting+tarball#p9029

Thank you! :)


Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests