Page 1 of 1

failed upgrade: Could not run tar executable (RC=127)

Posted: 09 Apr 2013, 17:26
by amp3030
I am trying to upgrade from a perfectly working 1.7.5 to 1.7.8. I get this:

Code: Select all

    Ready to update.
    Work directory: /home/blah/blah/ttrss
    Checking for tar...
    Could not run tar executable (RC=127).


In the command line on the server, I can run and use 'tar' without any problem.

Re: failed upgrade: Could not run tar executable (RC=127)

Posted: 09 Apr 2013, 21:02
by amp3030
Any ideas? Could it have something to do with directory permissions?

Re: failed upgrade: Could not run tar executable (RC=127)

Posted: 09 Apr 2013, 21:21
by sleeper_service
amp3030 wrote:I am trying to upgrade from a perfectly working 1.7.5 to 1.7.8. I get this:

Code: Select all

    Ready to update.
    Work directory: /home/blah/blah/ttrss
    Checking for tar...
    Could not run tar executable (RC=127).


In the command line on the server, I can run and use 'tar' without any problem.


yes, but can the web server use tar without any problem? is it in it's path? does it have permissions?

Re: failed upgrade: Could not run tar executable (RC=127)

Posted: 09 Apr 2013, 22:00
by feader
amp3030 wrote:Any ideas? Could it have something to do with directory permissions?

Some spitballing: Does your server run PHP 5.3, and is safe_mode_exec_dir enabled, and tar isn't in that directories?

Re: failed upgrade: Could not run tar executable (RC=127)

Posted: 10 Jul 2013, 15:21
by andryyy
Hello,

I did submit a fix for this:

https://github.com/andryyy/Tiny-Tiny-RS ... fc4055ba5c

It needs the PATH for which. Else the var is empty, but exit code 0.