HTTPS Howto?

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
graymattr
Bear Rating Trainee
Bear Rating Trainee
Posts: 24
Joined: 29 Apr 2013, 02:46

HTTPS Howto?

Postby graymattr » 30 Apr 2013, 06:24

Just wondering if anyone could point me to, or write up a way to implement SSL (HTTPS) for a tt-rss instance? I gave it a go today, but found that I was getting errors (tracebacks when accessing preferences, etc). I've not set up SSL previously, so I could use a walkthrough if someone would be kind enough to direct me to one.

Just to be clear, I read through the SSL certificate page in the wiki, but I am looking to get a CA signed SSL cert (rather than a self signed one) to encrypt my connection to my tt-rss instance.

Cheers!

AngryChris
Bear Rating Master
Bear Rating Master
Posts: 135
Joined: 08 Apr 2013, 02:42

Re: HTTPS Howto?

Postby AngryChris » 30 Apr 2013, 06:51


gbcox
Bear Rating Master
Bear Rating Master
Posts: 149
Joined: 25 Apr 2013, 04:52

Re: HTTPS Howto?

Postby gbcox » 30 Apr 2013, 08:01

There is a very good tutorial here. It is Fedora and Nginx (which I recommend, btw) specific, but should help you out even if you aren't using either...
https://getpantheon.atlassian.net/wiki/ ... y+Tiny+RSS

jakob42
Bear Rating Trainee
Bear Rating Trainee
Posts: 15
Joined: 20 Mar 2013, 16:43

Re: HTTPS Howto?

Postby jakob42 » 30 Apr 2013, 13:07

There isn't a good way to help you without more info. Google a SSL howto for your distro and your webserver and then change the url as AngryChris said. There is nothing more you need to do. On the topic of SSL certificate, http://www.startssl.com/ worked fine for my personal tt-rss instance.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: HTTPS Howto?

Postby fox » 30 Apr 2013, 13:22

Moving to support because there's no KB material here. Also, "plz halp I can't setup mah server https" sounds like offtopic to me.

jmozmoz
Bear Rating Trainee
Bear Rating Trainee
Posts: 26
Joined: 14 Apr 2013, 18:07

Re: HTTPS Howto?

Postby jmozmoz » 30 Apr 2013, 16:06


graymattr
Bear Rating Trainee
Bear Rating Trainee
Posts: 24
Joined: 29 Apr 2013, 02:46

Re: HTTPS Howto?

Postby graymattr » 30 Apr 2013, 21:46

Thanks for the tips. I'll do some reading, and check my config.

jchristi
Bear Rating Trainee
Bear Rating Trainee
Posts: 17
Joined: 03 Apr 2013, 21:18

Re: HTTPS Howto?

Postby jchristi » 01 May 2013, 06:59

great tip jmozmoz!

justauser
Bear Rating Master
Bear Rating Master
Posts: 133
Joined: 23 Mar 2013, 20:37

Re: HTTPS Howto?

Postby justauser » 01 May 2013, 21:20

Here is a link on how to create self-signed certificates for lighttpd:


graymattr
Bear Rating Trainee
Bear Rating Trainee
Posts: 24
Joined: 29 Apr 2013, 02:46

Re: HTTPS Howto?

Postby graymattr » 02 May 2013, 01:24


xtaz
Bear Rating Master
Bear Rating Master
Posts: 174
Joined: 24 Dec 2009, 16:48

Re: HTTPS Howto?

Postby xtaz » 02 May 2013, 12:21

That looks horribly broken. Your PHP interpreter is actually crashing and the PHP errors look like the files are corrupted or something. You sure you don't have any hardware or filesystem corruption issues on the server itself?

graymattr
Bear Rating Trainee
Bear Rating Trainee
Posts: 24
Joined: 29 Apr 2013, 02:46

Re: HTTPS Howto?

Postby graymattr » 02 May 2013, 18:55

Not that I'm aware of, no. There's another wordpress site running on this server, which seems to work fine. It's odd too that if I dont connect over port 443, I dont see any of these errors.

Perhaps it is time for a reinstall of tt-rss...

graymattr
Bear Rating Trainee
Bear Rating Trainee
Posts: 24
Joined: 29 Apr 2013, 02:46

Re: HTTPS Howto?

Postby graymattr » 02 May 2013, 22:37

Super odd. By loading the https:// site, I can trigger these apache errors every time. If I use port 80, no errors at all, even after long periods. I even reinstalled tt-rss and cleaned up my config.php (extra tabs) and themes (extra whitespace/tabs).

Is it possible something in my sites-available is to blame? Is there the apache default suitable for tt-rss?

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: HTTPS Howto?

Postby sleeper_service » 03 May 2013, 08:38


Athanasius
Bear Rating Trainee
Bear Rating Trainee
Posts: 38
Joined: 02 Apr 2013, 21:01

Re: HTTPS Howto?

Postby Athanasius » 03 May 2013, 10:47

Try googling that "Segmentation fault" error and you quickly end up at http://stackoverflow.com/questions/7745 ... e-error-lo which has a few suggestions on how to proceed.

Depending on your server configuration this could be as 'simple' as needing to tweak some memory limits. I don't know how defensively PHP is coded against memory exhaustion.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 13 guests