Label Number and Article Count Not Matching

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
RSS YOGI
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 22 Apr 2013, 14:24

Label Number and Article Count Not Matching

Postby RSS YOGI » 26 Jun 2013, 15:59

Hi All,

After long search of this forum, FAQs and Google, I had to seek your help by posting my query here. :D

I have set up filters and labels for some keywords. The problem now is that the Label count and the number of articles it displays are not matching with any combination of views (All Articles+Default, Unread articles etc).

Ex: If the label displays count as 50, the number of articles that I can read/see/access are 22. :shock:

Am I missing something here? Any help in this regard would be appreciated! :) :mrgreen:

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Label Number and Article Count Not Matching

Postby fox » 26 Jun 2013, 16:08

If the counter is gray it shows total amount of stored articles matching the label which could be larger than the amount of unread ones.

If you mean the Labels category counter, it includes all label counters which could contain duplicates (e.g. one article is labeled both A and B, labels category counter will show 2).

RSS YOGI
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 22 Apr 2013, 14:24

Re: Label Number and Article Count Not Matching

Postby RSS YOGI » 26 Jun 2013, 16:20

Thanks for the quick reply Fox! :D

Your reply sure clarifies, but Alas!, kindly note that the counter is not 'grey' as shown here
Label Counter.PNG
Label Counter
Label Counter.PNG (3.95 KiB) Viewed 4379 times


Am I missing something? :?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Label Number and Article Count Not Matching

Postby fox » 26 Jun 2013, 16:26

One more time: imagine an article filed under two labels. This will set total labels counter to 2 but your global unread will still show 1.

RSS YOGI
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 22 Apr 2013, 14:24

Re: Label Number and Article Count Not Matching

Postby RSS YOGI » 27 Jun 2013, 16:33

Thanks for the second explanation Fox! :D me a dumbo sometimes... get it on a second whack! :)

But again, I beg to differ on what I am seeing here - In the screenshot below, you can see that the Label article count reads '1401', while i could select only '88' articles even after scrolling to the end of the list. Shouldn't I be able to see all '1401' articles that have been labelled? :?

Again, appreciate your time on answering to this dumbo :D :mrgreen:

PS: There is only one label
Attachments
Label No.PNG
Label No.PNG (48.43 KiB) Viewed 4289 times

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Label Number and Article Count Not Matching

Postby fox » 27 Jun 2013, 16:43

Hmmm. I dunno. It's been quite a while since I found any problems with the way counters are calculated, though.

RSS YOGI
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 22 Apr 2013, 14:24

Re: Label Number and Article Count Not Matching

Postby RSS YOGI » 27 Jun 2013, 16:54

It would be really helpful, Fox.. if you can take a crack in solving this delicious mystery.. :D Coz, I think this is the most rocking feature of TTRSS, apart from many others...and sets it apart from other look alikes :) :mrgreen: Yay!!

User avatar
tjh
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 04 Apr 2013, 01:17
Location: Napier, New Zealand
Contact:

Re: Label Number and Article Count Not Matching

Postby tjh » 01 Jul 2013, 03:49

I'm seeing a similar issue - screenshot attached:

The problem I've found is that if I add a RSS Feed, but then delete it quickly (my firefox seems to auto-add any RSS feed I click on these days!), the articles it collected are counted and even shown, even though that feed isn't configured anymore.

2013-07-01_114259.png
2013-07-01_114259.png (60.14 KiB) Viewed 4244 times


The thing is, the Feed that generated all those TiM entries was deleted straight away.

I can reproduce this issue by adding, then quickly deleting, a feed.

If you feel it's worthwhile I shall submit a proper bug report, but here's a quick summary of my setup:

Code: Select all

TinyTinyRSS v1.8.0
Apache/2.2.16
PHP 5.3.3-7+squeeze15
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with eAccelerator v1.0-dev, Copyright (c) 2004-2012 eAccelerator, by eAccelerator
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
MySQL 5.1.66-0+squeeze1


Please, fox, don't yell at me too loudly! :)

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Label Number and Article Count Not Matching

Postby fox » 01 Jul 2013, 10:05

If you delete stuff, counter caches should be deleted with it (unless you run tt-rss on myisam or something which means your database is completely fucked).

You can try deleting everything from ttrss_counters_cache and ttrss_cat_counters_cache to see if it fixes things. The caches will be regenerated next time feeds are updated.

User avatar
tjh
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 04 Apr 2013, 01:17
Location: Napier, New Zealand
Contact:

Re: Label Number and Article Count Not Matching

Postby tjh » 01 Jul 2013, 13:28

Oh God, my worst fears have come true, I am going to get yelled at.

I am using MYISAM as my database type. I had no idea it would cause these problems.

Does the documentation mention this? Or is it just understood I shouldn't be a total inept muppet and have some vague clue about Databases?

Ok. I'm ready...
Unleash the rage.

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Label Number and Article Count Not Matching

Postby sleeper_service » 01 Jul 2013, 14:25

tjh wrote:Oh God, my worst fears have come true, I am going to get yelled at.

I am using MYISAM as my database type. I had no idea it would cause these problems.

Does the documentation mention this? Or is it just understood I shouldn't be a total inept muppet and have some vague clue about Databases?



how did you manage to be using myisam, given that the db creation schema specifies innodb?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Label Number and Article Count Not Matching

Postby fox » 01 Jul 2013, 15:10

tjh wrote:I am using MYISAM as my database type. I had no idea it would cause these problems.


There is no point in raging but your database *is* properly fucked. Your best best is exporting your opml and starting from scratch on innodb.

Edit: are you sure though? I think you need to modify the schema to import stuff as myisam, as it does explicitly set engine=innodb for tables.

User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Label Number and Article Count Not Matching

Postby blainemono » 01 Jul 2013, 15:14

tjh wrote:Does the documentation mention this?


No, as far as I know there is no explicit mention of this precise way to fuck yourself in the ass with barbed wire in the documentation.

There are some hints though.

And you could have searched the forum.

User avatar
tjh
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 04 Apr 2013, 01:17
Location: Napier, New Zealand
Contact:

Re: Label Number and Article Count Not Matching

Postby tjh » 01 Jul 2013, 15:34

Yea, so I'm an idiot.

Many years ago when I first setup my Debian server, I kept skip-innodb uncommented in /etc/mysql/my.cnf. Well, for years it wasn't even there, then when innodb make it into mysql, I thought "I don't need that!" and kept it turned off for the alleged memory savings.

Anyway, I have commented that statement, restarted mysql, and then converted all tables to innodb.

So blainemono you're right, I should have searched. My bad - From my experience with DB's, the type has never been an issue before so I, wrongly, assumed that it couldn't be anything to do with this issue.

fox & sleeper_service: I trust this explains how I managed to end up in this state. I would have thought mysql would have moaned at me during the initial creation steps, but let's face it, it's mysql.

I'll now nip out the back and punch myself a few times, as per protocol.

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Label Number and Article Count Not Matching

Postby sleeper_service » 01 Jul 2013, 15:57

tjh wrote:I'll now nip out the back and punch myself a few times, as per protocol.


I'm torn between

good to see someone that understands the proper order of things here,
and
I didn't realize that was part of the rules, but that does clear up a few questions.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 6 guests