Google detects my server as a bot since I run TT-RSS

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
vl33d
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 23 Jul 2013, 09:01

Google detects my server as a bot since I run TT-RSS

Postby vl33d » 23 Jul 2013, 09:06

Hello, TT-RSS is working fine on my debian 7 virtual private server. I just configured the update daemon, and I have 21 active RSS feeds.

The problem is, that when I browse the web through a SSH tunnel, Google asks me to type a captcha because of unusual traffic coming from my IP adress.

I checked my feeds manually, none of them comes from google.com.

Have anybody experienced a similar issue ?

I have also a citadel mail server running and a Zerobin app. But I ran those before and never had such a problem.

Thanks.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Google detects my server as a bot since I run TT-RSS

Postby fox » 23 Jul 2013, 09:11

I like how google decides what is and isn't unusual. Maybe you should use some other service which doesn't try to police your internet connection.

Edit: also I fail to see how is this related to tt-rss in any way.

phz
Bear Rating Disaster
Bear Rating Disaster
Posts: 77
Joined: 18 Mar 2013, 18:32

Re: Google detects my server as a bot since I run TT-RSS

Postby phz » 23 Jul 2013, 11:09


User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Google detects my server as a bot since I run TT-RSS

Postby fox » 23 Jul 2013, 11:26

Feedburner leaking connection information to google search sounds like a privacy fucking nightmare.

lbb
Bear Rating Trainee
Bear Rating Trainee
Posts: 7
Joined: 18 Jun 2013, 20:30

Re: Google detects my server as a bot since I run TT-RSS

Postby lbb » 23 Jul 2013, 11:28

You say it's a virtual private server, the issue might as well be caused by other servers in the same server facility. Maybe one of them downloads Youtube videos all day, or whatever. Or your ssh proxy isn't configured properly.

User avatar
raindog469
Bear Rating Trainee
Bear Rating Trainee
Posts: 17
Joined: 17 Mar 2013, 22:35

Re: Google detects my server as a bot since I run TT-RSS

Postby raindog469 » 23 Jul 2013, 11:30


User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Google detects my server as a bot since I run TT-RSS

Postby fox » 23 Jul 2013, 11:37


jdelamater99
Bear Rating Master
Bear Rating Master
Posts: 109
Joined: 11 Apr 2013, 17:45

Re: Google detects my server as a bot since I run TT-RSS

Postby jdelamater99 » 23 Jul 2013, 12:06

Does it only do this when using SSH tunneling? If so that could be your problem. It could also be that Google doesn't like the port that is being used.

Another thing, how does Google know? Are you using them for your DNS server?

vl33d
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 23 Jul 2013, 09:01

Re: Google detects my server as a bot since I run TT-RSS

Postby vl33d » 23 Jul 2013, 13:33

Thanks for all your answers, great to be listened to ;)

Actually, I didn't know feedburners was google's crap, so I just deleted all the feedburner feeds (what about feedportal ?). My update frequency was proabaly too high (15 min), so I lowered it to 30 min.

I'll let you know if it gets back to normal.

I feel a little bit depressed : I chose to go for RSS feeds to escape the news.google.com portal I was addicted to, but I just returned to google's crappy hands, without noticing it :(.

Now, as for the virtual private server, no I have my own personal IP adress, so even if the CPU/disk space are shared, my connection is dedicated, so I am the only one responsible (or my server) of this "ban".

As for SSH tunelling : the tunnel is between a local machine and the server, the tunnel is dynamic, so if my machine uses the 80 or the SSL port, the remote server uses the same. It worked well before.

How does google know ? I just talk about google searches, web browsing away from google works very well, but we know now, google is everywhere :'(.

See that sad link :

http://www.wired.com/wiredenterprise/20 ... t-traffic/

supersmurf
Bear Rating Trainee
Bear Rating Trainee
Posts: 3
Joined: 26 Mar 2013, 00:38

Re: Google detects my server as a bot since I run TT-RSS

Postby supersmurf » 23 Jul 2013, 14:59


ux2063
Bear Rating Trainee
Bear Rating Trainee
Posts: 14
Joined: 30 Apr 2013, 05:00

Re: Google detects my server as a bot since I run TT-RSS

Postby ux2063 » 23 Jul 2013, 15:34

I get this problem regularly.
The problem existed before I used tt-rss and it still exists now I do, so it has nothing to do with tt-rss.
Google is very keen on collecting as much information about you as is possible. That captcha stuff is part of it (more or less).
I know for sure that if you apply enough measures to counteract commercial crap on websites you will see those captchas.
I use Firefox with Adblock Plus and I run my own DNS server and a filtering proxy in addition, so virtually no commercial stuff gets through and I get those captchas from time to time.
Interestingly I do not get them always. Google does not want you to scare away permanently.
Since a few days I get a captcha sometimes so apparently they've started another teaser campaign.
As you stated yourself they own a lot of RSS services. When the commercial stuff is blocked they'll know it and hence the annoying captchas.

jdelamater99
Bear Rating Master
Bear Rating Master
Posts: 109
Joined: 11 Apr 2013, 17:45

Re: Google detects my server as a bot since I run TT-RSS

Postby jdelamater99 » 23 Jul 2013, 16:18


vl33d
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 23 Jul 2013, 09:01

Re: Google detects my server as a bot since I run TT-RSS

Postby vl33d » 23 Jul 2013, 19:55

Seems to work, as said before, I removed all the feedburner's feeds and changed the update frequency to 30 min. No captcha at all tonight ;)

vl33d
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 23 Jul 2013, 09:01

Re: Google detects my server as a bot since I run TT-RSS

Postby vl33d » 23 Jul 2013, 19:56



Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests