Page 1 of 2

I think I'm losing my mind

Posted: 28 Dec 2013, 06:20
by thermionic
I have a feed http://blogs.technet.com/b/privatecloud/rss.aspx in my tt-rss install, which appears to have content from http://blogs.technet.com/b/ponicke/ in it

I'm running v1.11.d31d521

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 06:22
by thermionic
On deleting the feed and adding it again, it now has the correct content in it again

I haven't a clue what happened.

If it happens again, I'll try and remember to collect up logs rather than just deleting the feed and adding it again.

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 06:25
by thermionic
okay, I've got another one

a feed with http://blogs.technet.com/b/askds/rss.aspx but appears to have the content from http://blogs.technet.com/b/markrussinovich/rss.aspx

I'll leave this one in place till somebody more capable then myself can tell me where I can find the appropriate logs

Cheers

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 06:36
by sleeper_service
have you considered seeking professional help? perhaps they can help you find your mind? :)

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 06:39
by thermionic
I'd settle for finding the logs :-)

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 06:59
by thermionic
I'm using update_daemon2.php /var/log/ttrssupdater.log is empty, hence the comment about finding the logs

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 07:07
by thermionic
in addition to the first one that was "fixed" by deleting and re-adding it, I've got 4 more feeds where the contents of the feed in tt-rss is from a completely different feed.

well, not completely different, all of the affected feeds are on http://blogs.technet.com as are all of the feeds that have replaced them.

I do have af_feedmod enabled, but I don't have an entry that covers any of these feeds, I don't think I have anything else installed that could be doing this to a feed.

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 07:25
by sleeper_service
what are these logs you speak of? you could tell update_daemon2.php to run in a verbose mode and that'd give you logs.

I've no clue what your /var/log/ttrssupdater.log is, cuz that's not part of the standard distribution.

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 07:47
by thermionic
I've got a feeling that the /var/log/ttrssupdater is just being rotated, I'm running git trunk, not from a package.

How would I start update_daemon2.php to run in verbose mode ?

I'm currently starting it as a service (Ubuntu 12.04) with

Code: Select all

description "tt-rss updater"
start on started mysql
stop on stopping mysql
respawn
respawn limit 2 1
setuid www-data
setgid www-data
exec /var/www/tt-rss/update_daemon2.php

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 08:56
by sleeper_service
don't run it in quiet mode?

perhaps you've never run it standalone and watched how much it spews out.

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 11:15
by fox
mysql + myisam tables?

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 16:29
by thermionic
I stopped running update_daemon2.php and ran

./update.php --force-update --log /var/log/ttrssmanual.log
then
./update.php --feeds --log /var/log/ttrssmanual.log

Code: Select all

[12:07:11/7251] Lock: update.lock
[12:07:11/7251] marking all feeds as needing update...
[12:08:26/7414] Lock: update.lock
[12:08:26/7414] Scheduled 96 feeds to update...


then had a log full of entries like

Code: Select all

[12:09:25/7414] Base feed: http://blogs.technet.com/b/askds/rss.aspx
[12:09:25/7414]  => 1970-01-01 00:00:00, 17 2


which ended in

Code: Select all

[12:14:24/7414] All done.
[12:14:24/7414] cache/simplepie: removed 0 files.
[12:14:24/7414] cache/images: removed 0 files.
[12:14:24/7414] cache/export: removed 0 files.
[12:14:24/7414] cache/upload: removed 0 files.
[12:14:24/7414] Removed 0 old lock files.
[12:14:24/7414] Removing old error log entries...
[12:14:24/7414] Feedbrowser updated, 0 feeds processed.
[12:14:25/7414] Purged 8 orphaned posts.
[12:14:26/7414] Cleaned 0 cached tags.


I'm guessing I need a more verbose option

The database is MySQL with InnoDB

Code: Select all

mysql> SELECT table_name FROM INFORMATION_SCHEMA.TABLES   WHERE engine = 'MyISAM';
+---------------------------+
| table_name                |
+---------------------------+
| COLUMNS                   |
| EVENTS                    |
| PARAMETERS                |
| PARTITIONS                |
| PLUGINS                   |
| PROCESSLIST               |
| ROUTINES                  |
| TRIGGERS                  |
| VIEWS                     |
| columns_priv              |
| db                        |
| event                     |
| func                      |
| help_category             |
| help_keyword              |
| help_relation             |
| help_topic                |
| host                      |
| ndb_binlog_index          |
| plugin                    |
| proc                      |
| procs_priv                |
| proxies_priv              |
| servers                   |
| tables_priv               |
| time_zone                 |
| time_zone_leap_second     |
| time_zone_name            |
| time_zone_transition      |
| time_zone_transition_type |
| user                      |
+---------------------------+
31 rows in set (0.00 sec)

mysql> SELECT table_name FROM INFORMATION_SCHEMA.TABLES   WHERE engine = 'InnoDB';
+--------------------------+
| table_name               |
+--------------------------+
| ttrss_access_keys        |
| ttrss_archived_feeds     |
| ttrss_cat_counters_cache |
| ttrss_counters_cache     |
| ttrss_enclosures         |
| ttrss_entries            |
| ttrss_entry_comments     |
| ttrss_error_log          |
| ttrss_feed_categories    |
| ttrss_feedbrowser_cache  |
| ttrss_feeds              |
| ttrss_filter_actions     |
| ttrss_filter_types       |
| ttrss_filters2           |
| ttrss_filters2_actions   |
| ttrss_filters2_rules     |
| ttrss_labels2            |
| ttrss_linked_feeds       |
| ttrss_linked_instances   |
| ttrss_plugin_storage     |
| ttrss_prefs              |
| ttrss_prefs_sections     |
| ttrss_prefs_types        |
| ttrss_sessions           |
| ttrss_settings_profiles  |
| ttrss_tags               |
| ttrss_user_entries       |
| ttrss_user_labels2       |
| ttrss_user_prefs         |
| ttrss_users              |
| ttrss_version            |
+--------------------------+
31 rows in set (0.01 sec)

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 18:16
by thermionic
not sure if it's any help, but I did f shifht d on one of the "problem" feeds

the feed URL is http://blogs.technet.com/b/askds/rss.aspx

the f shift d output is here http://pastebin.com/2i638biw

the top article in the feed has the URL http://blogs.technet.com/b/markrussinov ... 43763.aspx

I added the feed that this would have come from (it wasn't previously in my tt-rss) http://blogs.technet.com/b/markrussinovich/rss.aspx and it shows no entries, the output from f shift d from that feed is here http://pastebin.com/axnQmFwv

It's as if some of the technet feeds are being substituted somewhere, but I'm at a loss as to where.

if there was a SQL command I could run to disable updates for all feeds, I could then manually enable updates for the problem feeds and do a packet capture if that would help at all.

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 18:57
by AngryChris
thermionic wrote:if there was a SQL command I could run to disable updates for all feeds, I could then manually enable updates for the problem feeds and do a packet capture if that would help at all.

You're in luck! There is such a SQL statement!

Code: Select all

ttrssdb=> UPDATE ttrss_feeds SET update_interval='-1';

This should disable updates for every feed in the database. Add a WHERE clause if you want to limit it to just your feeds or whatever. Here are my disabled feeds as an example:

Code: Select all

ttrssdb=> select owner_uid, title, update_interval from ttrss_feeds where update_interval < '0';
 owner_uid |           title            | update_interval
-----------+----------------------------+-----------------
         2 | Vienna Developer Blog      |              -1
         2 | Vienna Support             |              -1
(2 rows)

ttrssdb=>

You can set them all back to the default interval thusly:

Code: Select all

ttrssdb=> UPDATE ttrss_feeds SET update_interval='0';

Re: I think I'm losing my mind

Posted: 28 Dec 2013, 23:52
by thermionic
I disabled updates on all feeds, and then enabled updates one of the feeds with the "wrong" content http://blogs.technet.com/b/mfugatt/rss.aspx

The packet capture is here http://www.cloudshark.org/captures/6c5b7f40e3c7 As can be seen on line 78, the GET is correct

I'd be happy to do any more investigation, but I think I'm going to just delete each feed and then add it again.

Fox, I can send you a zipped database dump (~18Mb) if you're interested in investigating further.