Page 1 of 1

Cannot Enable Plugins

Posted: 31 Mar 2014, 00:58
by benson
I had this issue after upgrading and thought it was a particular plugin previously. Now I did a fresh install and I cannot enable any plugins.

Setup:
Fresh install of v1.12 in a new sub-directory off the old install (site.com/new)
Brand new PostgreSQL database (nothing else in it - previous installs used mysql, this is the first one using PostgreSQL)
This is all on a private server (not shared hosting)

What I see in my plugins in the preferences page is a list of the plugins. I click the checkmark to install, click the enable button, it refreshes, and nothing has happened.

My plugins line from config.php:

Code: Select all

define('PLUGINS', 'auth_internal, note, updater');


I also just verified both users (admin and user1) are set to access_level = 10 (neither user can enable plugins)

Please let me know if you need more info.

Re: Cannot Enable Plugins

Posted: 31 Mar 2014, 03:34
by charlie-tca
I also just verified both users (admin and user1) are set to access_level = 10 (neither user can enable plugins)


I might be all messed up here, but if neither user can enable plugins, then the plugins are working correctly if they will not enable.

Re: Cannot Enable Plugins

Posted: 31 Mar 2014, 08:45
by fox
Could be something browser-related.

Re: Cannot Enable Plugins

Posted: 31 Mar 2014, 19:16
by benson
Looks like it was browser related. The issue appears with Chrome v33 (at least I can reproduce it with Chrome v33 repeatedly on different machines). Using Firefox, I was able to enable plugins with both users with no issues.

Thanks for the help.

Re: Cannot Enable Plugins

Posted: 31 Mar 2014, 19:49
by fox
Try in chrome incognito mode, could be some addon breaking things.

Re: Cannot Enable Plugins

Posted: 31 Mar 2014, 19:57
by benson
One of the extensions is breaking it. Incognito mode worked fine. Weirdly, I only have AdBlock Plus, LastPass, Send to Instapaper, Google Chromecast, and Google Docs. Since I also have AdBlock Plus and LastPass on Firefox, it is probably one of the Google extensions.

Again, thanks for the help.

Re: Cannot Enable Plugins

Posted: 31 Mar 2014, 20:51
by martywd
benson wrote:One of the extensions is breaking it. Incognito mode worked fine. Weirdly, I only have AdBlock Plus, LastPass, Send to Instapaper, Google Chromecast, and Google Docs. ...


FWIW, I just tried changing a plugin pref (tt-rss v1.12) with chromium-browser [33.0.1750.152 (Developer Build 256984) Built on Ubuntu 13.10, running on LinuxMint 16] in standard mode (not Incognito) . I also have: 'LastPass', 'AdBlock Plus' extensions installed. Inaddition, 'ScriptSafe' (domain serving tt-rss: 'Allowed') and 'Vanilla Cookie Manager' which block or remove stuff are also installed in the chromium-browser on the machine which I ran this 'test'. I do not have 'Send to Instapaper', 'Google Chromecast', and 'Google Docs' extensions you mention installed.

With that typed, enabling the plugin pref (af_comics) and saving, remains enabled after 'save' in the version of chromium-browser I'm running. For me, at least, 'Adblock Plus' and 'LastPass' are not causing a tt-rss 'prefs save' issue in chromium-browser.
.

Re: Cannot Enable Plugins

Posted: 01 Apr 2014, 17:55
by mrc0mmand
I tried enabling/disabling a plugin in chrome (33.0.1750.154, Windows 7; tt-rss 1.12 with PostgreSQL) and had no problems with it. I have AdBlock, ScriptSafe and DoNotTrackMe installed.

Re: Cannot Enable Plugins

Posted: 11 Mar 2015, 12:03
by therefromhere
I'm hitting this bug on Chrome, and I'm fairly sure it's the LastPass extension that's causing it. Tested by toggling this and other extensions + trying to enable/disable plugins - it's only broken when LastPass is enabled.

Google Chrome Version Version 41.0.2272.89 m, on Windows 8
LastPass extension "Version: 3.1.91 Updated: 12 February 2015"
ttrss version v1.15.3.60ef62b

Re: Cannot Enable Plugins

Posted: 11 Mar 2015, 12:16
by fox
anyone knows if its possible to somehow detect lastpass extension being active?

asking for a friend

Re: Cannot Enable Plugins

Posted: 11 Mar 2015, 13:56
by vip

Re: Cannot Enable Plugins

Posted: 11 Mar 2015, 14:03
by fox
jesus

yes hi we made a software which arbitrarily breaks shit in your forms by assigning field values based on different forms

enjoy

FUCK

e: im gonna link to your post in the lastpass is shit stickied thread

Re: Cannot Enable Plugins

Posted: 11 Mar 2015, 15:03
by vip
Oh, I'm just mentioning, that somebody lacks forum searching ability. Fuck.