Feed error after 1.12 update - SOLVED

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Feed error after 1.12 update - SOLVED

Postby joshp » 06 May 2014, 19:42

I have a feed that runs from a private site that worked fine until the latest upgrade. I ran it through the my feed sucks tool and it came back as bad, giving me the same error as my installation. This is the error:

Error: LibXML error 4 at line 1 (column 1): Start tag expected, '<' not found

I am trying to fix the issue, I posted on the forum of the private site, searched the forums, read all sickies, etc.

I cannot determine the problem. Here is the opening line of the feed:

<?xml version="1.0" encoding="UTF-8" ?> <rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">

It appears fine. The error line 1 column 1 reference, is that to the feed or to the libxml code, because the feed seems right.

I installed the xmllint plugin, and there is no change.

Any help would be appreciated.

Josh

Sent from my LG-LS970 using Tapatalk
Last edited by joshp on 07 May 2014, 03:49, edited 1 time in total.

User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Re: Feed error after 1.12 update

Postby joshp » 06 May 2014, 19:51

When testing the feed in other feed testers out there, line one comes back as this

Your ip does not match one authorized for your account, you connected from 1 ...

Which is what I would assume is causing the error. I am trying to work around this at the site in question, but is there a way to work around this from my server/ttrss installation side?

User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Re: Feed error after 1.12 update - SOLVED - SOLUTION

Postby joshp » 07 May 2014, 03:53

I don't know what changed in the way 1.12 parsed the feed, but the error was a legit one, since the private site that I used needed to associate only one IP address to my account on their site, and I had another IP already assigned. Their way to handle that is to send back the error message as line one of the rss feed, and that error was not coded as xml.

The solution was to register the IP address of my reader with them as a legitimate IP associated with my account, allowing connections from both my regular IP, and the IP of my hosted server. I hope this helps someone with a similar problem.

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Feed error after 1.12 update - SOLVED

Postby sleeper_service » 07 May 2014, 04:11

so, in other words, PEBKAC...

User avatar
joshp
Bear Rating Disaster
Bear Rating Disaster
Posts: 50
Joined: 31 Mar 2011, 11:31

Re: Feed error after 1.12 update - SOLVED

Postby joshp » 07 May 2014, 04:17

sleeper_service wrote:so, in other words, PEBKAC...


:) I can admit that :)

There was never a problem with that feed before, so I was really confused, and when I tested the feed from my home IP address, it was returning valid. So I suppose I could have seen that sooner, but I did see it, so... SEBKAC. I still wonder if there is a way to accommodate for that from the server side, since the solution required cooperation from a third party, and that is not always reliable.

Zorchenhimer
Bear Rating Trainee
Bear Rating Trainee
Posts: 8
Joined: 07 Apr 2014, 05:45

Re: Feed error after 1.12 update - SOLVED

Postby Zorchenhimer » 07 May 2014, 08:52

sleeper_service wrote:so, in other words, PEBKAC...


Sounds more like terrible programming on their side. Why serve broken XML instead of a proper HTTP status code? That's exactly why HTTP 401 Unauthorized and HTTP 403 Forbidden exist.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests