Combined Feed Display breaks images/embeds?

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
elforesto
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 21 Mar 2013, 07:33

Combined Feed Display breaks images/embeds?

Postby elforesto » 24 Jul 2014, 05:25

I just updated from 1.8 to 1.13 (yes, I dragged my feet; I suck). I deleted all of the files in my TTRSS folder, dropped my plugins and themes back in place, and updated config.php with the new directives. When I enable combined feed display, all of the embedded images in my browser are broken. Instead, I see links to the images with some broken embed tags. When I disable combined feed display or use mobile, it looks fine. I've already disabled all plugins and reverted to the default theme without any changes.

Any ideas on what I should look at next? This has me stumped.

bonelifer
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 26 Jul 2013, 05:04

Re: Combined Feed Display breaks images/embeds?

Postby bonelifer » 24 Jul 2014, 07:33

I'm getting the same thing.

mangled.jpg
mangled.jpg (133.79 KiB) Viewed 3370 times

elforesto
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 21 Mar 2013, 07:33

Re: Combined Feed Display breaks images/embeds?

Postby elforesto » 24 Jul 2014, 19:09

Yep, that's exactly that I'm seeing. It's like the < is getting stripped from all tags in the article, but ONLY when using the combined feed view.

I'm going to poke around in the source and see if I can find a cause/fix.

elforesto
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 21 Mar 2013, 07:33

Re: Combined Feed Display breaks images/embeds?

Postby elforesto » 24 Jul 2014, 19:42

I think I found the problem. It wasn't working properly in Chrome 36, so I tried IE11 and everything loaded as expected. I started disabling browser extensions one at a time and found that Clickable Links was causing the issue. The extension had stopped updating and must've broken. I removed it, found an updated version in the Chrome Store, and everything works as expected now.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Combined Feed Display breaks images/embeds?

Postby fox » 24 Jul 2014, 19:47

This extension shit is getting out of hand, seriously.

bonelifer
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 26 Jul 2013, 05:04

Re: Combined Feed Display breaks images/embeds?

Postby bonelifer » 24 Jul 2014, 21:56

elforesto wrote:I think I found the problem. It wasn't working properly in Chrome 36, so I tried IE11 and everything loaded as expected. I started disabling browser extensions one at a time and found that Clickable Links was causing the issue. The extension had stopped updating and must've broken. I removed it, found an updated version in the Chrome Store, and everything works as expected now.


I use Linkificator in FF and apparently it was the cause. Just white listed my servers domain name and it was fixed.

elforesto
Bear Rating Trainee
Bear Rating Trainee
Posts: 12
Joined: 21 Mar 2013, 07:33

Re: Combined Feed Display breaks images/embeds?

Postby elforesto » 25 Jul 2014, 00:01

fox wrote:This extension shit is getting out of hand, seriously.


No argument here. Totally caught me off-guard since it didn't muck with 1.8.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests