HTTPS not working with Android client

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
dmeyer
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Feb 2015, 23:52

HTTPS not working with Android client

Postby dmeyer » 17 Feb 2015, 23:59

Hi,

first of all: great software. I love Tiny Tiny RSS and I really like the Android client. To make my domain more secure I got a certificates to only use https in the future. It works well with the browser, but the Android client gets an "IO Error" when trying to connect. Using http instead of https in the URL works with Android. curl -d '{"op":"login","user":"you","password":"xxx"}' in the shell also works without problems with http and https.

Does someone has an idea what I did wrong? If a developer needs more information, tell me what I also need to provide. The domain of my installation can be provided in a private mail, I do not want to post it here in public.

Thanks

ibreakcellphones
Bear Rating Trainee
Bear Rating Trainee
Posts: 31
Joined: 28 Mar 2013, 09:49

Re: HTTPS not working with Android client

Postby ibreakcellphones » 18 Feb 2015, 01:17

I had to import my certificate to be able to log in via https.

Put your certificate's PEM file on your phone somehow.

On my LG G3, go to Settings -> Security -> Install from Storage, select the file, and go.

dmeyer
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Feb 2015, 23:52

Re: HTTPS not working with Android client

Postby dmeyer » 20 Feb 2015, 21:23

Thanks, but it did not work. I still get an I/O error once I switch to https. I also tried to add the intermediate certificate to my phone but it still does not work. The certificate itself is valid but even with all checks in tt-rss turned off it does not work. Loading the https website with Google Chrome on Android does work, so it looks like a problem in tt-rss.

Additional information> Moto G (1. Gen) with 4.4.4 and a simple StartCom certificate.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: HTTPS not working with Android client

Postby fox » 20 Feb 2015, 21:50

works for me fine so idk

most likely you're one of those idiot retards who restricted the available protocols in misguided attempts to improve security so android http stack just refuses to deal with your shit now

dmeyer
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Feb 2015, 23:52

Re: HTTPS not working with Android client

Postby dmeyer » 21 Feb 2015, 23:30

Yes, I'm one of those, but I removed the restriction during testing before writing this post. :) And the browser on my phone is working with the the https url.

dmeyer
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Feb 2015, 23:52

Re: HTTPS not working with Android client

Postby dmeyer » 21 Feb 2015, 23:41

I just had the idea to try my tablet I normally don't use for RSS reading. That works. So I guess it is a problem with my phone. Android 5.0.x for Moto G should arrive soon, maybe the problem will go away by then.

nbx
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 23 Feb 2015, 13:11

Re: HTTPS not working with Android client

Postby nbx » 23 Feb 2015, 18:41

Spent a hours today to solve this.
Import DER-type certificate to your Android. Then you'll be able to correctly import it to Android.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests