Page 1 of 2

Debugging missing articles from feed

Posted: 21 Jan 2016, 14:38
by adhawkins
Hi,

I have noticed recently that some of my feeds don't seem to be picking up new articles. There is one feed in particular that's had no new articles show in ttrss for a month or so, yet I know new items have been posted (and I can see them in the RSS for the site).

Can anyone give me some steps as to how I might troubleshoot this? Any logging I can enable etc.? The version of ttrss installed is quite old (identifies itself as v1.10 in the web interface) so an upgrade might be in order. However, I'd like to understand what has caused this issue to start happening if at all possible.

I've been looking in the database, and can see that there are no entries in the 'ttrss_entries' table for this feed since the end of December.

Thanks in advance for any assistance you can offer.

Andy

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 14:44
by fox
stickied thread + search "feed debugger"

first of all update to latest git, it's pointless to debug an issue which might have been fixed literally years ago.

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 14:56
by adhawkins
Ok, I've run the feed (http://sniffpetrol.com/feed/) through the feed debugger at https://fakecake.org/myfeedsucks/

The only output I get is:

Code: Select all

Processing feed: http://sniffpetrol.com/feed/

Fetching URL (UA: Tiny Tiny RSS/16.1 (http://tt-rss.org/))


Does this mean the feed isn't being parsed properly?

Any suggestions as to why that might be? It's a fairly standard Wordpress feed as far as I can see.

Thanks

Andy

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 15:48
by rwa66
I just added your feed to my TTRSS and it works fine, latest article is of today 10:30.
So I guess it is time to upgrade TTRSS to the latest version.

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 16:05
by adhawkins
Ok, I'll give that a go. Thanks.

Andy

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 16:45
by adhawkins
Ok, done that and it now seems to be updating the feed. I wonder if there was some change in (say) Wordpress feeds that meant an appropriate update to ttrss was necessary?

Anyway, now running on current git version, so at least it'll be a bit easier to keep up to date in future.

Thanks for the help.

Andy

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 17:22
by fox
looks like trunk recent changes broke myfeedsucks, it should work now

Re: Debugging missing articles from feed

Posted: 21 Jan 2016, 18:02
by adhawkins
fox wrote:looks like trunk recent changes broke myfeedsucks, it should work now

It does indeed. A useful resource for the future.

At least this was the carrot I needed to update my installation to Git current. Will try to keep it up to date now!

Andy

Re: Debugging missing articles from feed

Posted: 22 Jan 2016, 00:31
by Nicola
hi, i have sam problem with version v16.1

Re: Debugging missing articles from feed

Posted: 22 Jan 2016, 13:34
by rwa66
What problem? Could you be more specific? We cannot read minds you know.
What feed? What is the outcome of that feed at https://fakecake.org/myfeedsucks/ ?

Re: Debugging missing articles from feed

Posted: 23 Jan 2016, 09:51
by Nicola
Hello
I try to explain it better. I tested the RSS with "fakecake" and is compliant. The problem comes with modified feed server side and already read by TT-RSS. In fact if you use the key combination "fD" i see properly feed but not displayed via the web interface (I visualize only articles to read), you must do a research setting to "All items". I would try to eliminate the single item in a week and see if the problem recurs.

Is there a way to delete single item from the database?

Thank you.

Re: Debugging missing articles from feed

Posted: 23 Jan 2016, 20:04
by JustAMacUser
You can delete an article by selecting it, then select Archive from the More menu. Then go to Archived articles, select the article, then select Delete from the More menu.

But most of your post is difficult to understand. Are you saying that an existing article is not being changed to reflect updates from the source feed?

Re: Debugging missing articles from feed

Posted: 23 Jan 2016, 22:18
by Nicola
Please excuse my English.
Yes, an existing article (server side) changed after a some time (a week, a month) is not marked as unread in ttrss.

Do you understand?

Re: Debugging missing articles from feed

Posted: 24 Jan 2016, 05:11
by JustAMacUser
Oh... That's a per-feed option. I know it's a stupid question, but do you have it enabled for the feed in question? Also, are you sure the article has not rolled off the source's feed?

Maybe paste the contents from the "f D" results so we can take a look.

Re: Debugging missing articles from feed

Posted: 24 Jan 2016, 11:09
by Nicola
Thanks for your time. To provide debugging ( fD) must wait for it to present an article that exhibits this symptom.
For the moment i can enable this option (per-feed option) ?

Thank you.