Issue with German site resolving to English

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
Striker21
Bear Rating Trainee
Bear Rating Trainee
Posts: 42
Joined: 27 Oct 2015, 00:30

Issue with German site resolving to English

Postby Striker21 » 25 Apr 2016, 22:36

Hi guys,

Setup; VPS, Ubuntu 14.04.3, MySQL, mariaDB 10.1.11, TT-RSS v16.1 (from here), 1k feeds.

I'm having an issue with business insider DE, UK and US sites.

When I fetch this URL I'm getting US or UK entries instead of the German ones.
http://www.businessinsider.de/rss

When I tested the feed on myfeedsucks it gets the German articles correct. Is there some logic that someone can point to as what to check in this case? If I visit the website the first time on my own PC I often get redirected to the English site, after switching via their selector things works. However not sure why the myfeedsucks test would work seemingly fine, but not my setup. Any and all thoughts welcome :)

Here's what my debug is telling me, tried with and without the extra URL parameters, added to try to solve, but did not solve.

Code: Select all

[19:13:37/24839] start
[19:13:37/24839] local cache will not be used for this feed
[19:13:37/24839] fetching [http://www.businessinsider.de/rss?IR=C/]...
[19:13:37/24839] fetch done.
[19:13:37/24839] saving cache/simplepie/fa9be4294c4de9d6daad8ae1780775ae34cc4ca8.xml
[19:13:37/24839] language: english
[19:13:37/24839] processing feed data...
[19:13:37/24839] site_url: http://uk.businessinsider.com/rss/?r=DE&IR=T
[19:13:37/24839] feed_title: Business Insider
[19:13:37/24839] checking favicon...
[19:13:37/24839] loading filters & labels...
[19:13:37/24839] 0 filters loaded.
[19:13:37/24839] processing articles...
[19:13:37/24839] guid 1,http://uk.businessinsider.com/light-l16-camera-of-the-future-2016-4 / SHA1:372c0609d895b1b8dfc290e2ee4989f7942c7f18


Chris

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Issue with German site resolving to English

Postby fox » 25 Apr 2016, 22:56

they likely go by your VPS geoip, not much you can do there i'm afraid (there's no accept-language or w/e support for feeds in tt-rss and i have doubts it would even work reliably)

>When I tested the feed on myfeedsucks it gets the German articles correct.

since the machine is physically in Russia they probably just serve the original language, at least that would be my guess

e: you can use wget or curl while logged in your VPS shell to see what kind of content it gets, it should be same language

Striker21
Bear Rating Trainee
Bear Rating Trainee
Posts: 42
Joined: 27 Oct 2015, 00:30

Re: Issue with German site resolving to English

Postby Striker21 » 26 Apr 2016, 00:20

Roger that, ugh, you are likely right, that sucks :) my server is in France so might default to the UK as there is no french version


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests