Broken Published feed

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
Latimer
Bear Rating Master
Bear Rating Master
Posts: 131
Joined: 17 Mar 2013, 19:35

Broken Published feed

Postby Latimer » 26 Apr 2016, 18:08

I managed to broke my Published feed by sharing the article from Android Police: http://www.androidpolice.com/2016/04/21 ... ule-is-up/

The error message is "LibXML error 62 at line 86 (column 59): Sequence ']]>' not allowed in content". Please see the attached file for the contents of the feed (I removed the rest of the entries, the feed key, and the domain name).

I'm running Tiny Tiny RSS v16.3 (9e84bab). Now, I do use to retrieve the full text of the Android Police feed, so maybe this has something to do with the issue. Unfortunately, I can't resubscribe to their feed, because the bad article is already gone.

PS> Things are predictably back to normal after removing the article from the Published feed.
Attachments
public.php.abridged.zip
(3.19 KiB) Downloaded 67 times

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Broken Published feed

Postby fox » 26 Apr 2016, 18:42

yep, there seems to be an extra closing CDATA tag part in the summary (which is generated as a substring of article content), i guess this can happen

maybe tt-rss should call sanitize() on that part too

Latimer
Bear Rating Master
Bear Rating Master
Posts: 131
Joined: 17 Mar 2013, 19:35

Re: Broken Published feed

Postby Latimer » 27 Apr 2016, 19:45

Actually it looks like it's working fine when I don't use feedmod, so there's nothing wrong with Tiny Tiny RSS.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Broken Published feed

Postby fox » 27 Apr 2016, 21:01

i'm going to add sanitize there anyway, maybe tomorrow

Latimer
Bear Rating Master
Bear Rating Master
Posts: 131
Joined: 17 Mar 2013, 19:35

Re: Broken Published feed

Postby Latimer » 27 Apr 2016, 23:05

Thanks, I'll check it out!

Meanwhile I disabled feedmod and tried enabling af_readability for the feed, and it worked really well.

Latimer
Bear Rating Master
Bear Rating Master
Posts: 131
Joined: 17 Mar 2013, 19:35

Re: Broken Published feed

Postby Latimer » 07 May 2016, 23:36

I just got a chance to check it out, and I think it's working, thanks!


Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests