Upgrading from a very old version

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
adude
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 19 Jul 2016, 21:38

Upgrading from a very old version

Postby adude » 19 Jul 2016, 21:41

Hi,

I have read about the switch to git and I think that's cool. I have an instance of 1.7.0 still running (I know, security updates and all) which I'd like to get up to date. What exactly would be the upgrade process for that? Can I just clone the repo and edit the config to make it use the old database?

User avatar
kierun
Bear Rating Trainee
Bear Rating Trainee
Posts: 27
Joined: 16 Feb 2016, 11:43

Re: Upgrading from a very old version

Postby kierun » 20 Jul 2016, 09:42

Take a backup of all your feeds (OPML), take a backup of your database, and a backup of your (old) ttrss install. Then, install from git, try to update the database. if that fails, junk it and restore your feeds via OPML. If it succeeds, you are done.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests