TT-RSS Does Not Like Being Used Through a Proxy Running on the Same Machine

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
User avatar
bedouin
Bear Rating Trainee
Bear Rating Trainee
Posts: 8
Joined: 30 Mar 2013, 23:43

TT-RSS Does Not Like Being Used Through a Proxy Running on the Same Machine

Postby bedouin » 18 Aug 2016, 07:25

I was baffled tonight. I run an ancient version of TT-RSS (1.7.5), but it's been working for years now on my similarly ancient Debian install, so no complaints from me.

I usually access TT-RSS through Tiny Reader on my iPhone/iPad. Tonight though I happened to login through the web interface.

I was greeted with errors containing text like, "Error, xhrFailed" and "[email protected]" (and stuff related to dojo). I did not document the errors in full; those are just some of the snippets I found in my browser's search history from when I was trying to find a solution.

I tried editing and deleting database variables and complete reinstalls (finding the old .deb package was difficult). I thought the problem stemmed from a change I made to the configuration file to reflect my web server's updated hostname. After a complete reinstall TT-RSS would load, but then stall at 50%; trying to access the prefs.php directly produced one of the aforementioned errors (I can't remember which).

Then I realized something. I run Squid + Privoxy on two separate machines for two separate connections. I switched my devices over to a proxy on a different machine a couple days ago, which also happens to be the machine TT-RSS runs on. I disabled the proxy and TT-RSS began working as usual. For whatever reason, TT-RSS does not like being accessed through a proxy on the same machine it runs on.

I spent probably three hours trying to figure out what was going on. I hope by writing this I might save someone the same trouble in the future. Perhaps this issue no longer exists in newer versions of TT-RSS. Oddly, Tiny Reader kept working throughout all of this. Thankfully I exported my feed URLs from the database before reinstalling, since there was no way for me to export them through TT-RSS given that I could not access the preferences.

Return to “Support”

Who is online

Users browsing this forum: No registered users and 11 guests