Firefox Integration broken

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
conrad784
Bear Rating Trainee
Bear Rating Trainee
Posts: 7
Joined: 30 Oct 2016, 23:54

Firefox Integration broken

Postby conrad784 » 31 Oct 2016, 00:32

Hi,

it's not a severe bug, but I noticed that the Firefox Integration is broken.

My tt-rss installation is on a subdomain: rss.*.de.
Latest git-version on Debian Jessie Stable with Apache2 + MariaDB.

Tested with FirefoxESR (45.4.0) and Development (51.0a2).
Both times with my usual profile and also a clean new profile.

I hope my pictures can help finding the bug.

Besides, nice work fox with tt-rss, using it a lot!
Conrad
Attachments
tt-rss_firefox2.JPG
tt-rss_firefox2.JPG (38.68 KiB) Viewed 5570 times
tt-rss_firefox.JPG
tt-rss_firefox.JPG (25.35 KiB) Viewed 5570 times

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Firefox Integration broken

Postby fox » 31 Oct 2016, 08:06

looks like firefox does urlencode() on url twice for some reason, i wonder why

i'll take a look later today

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Firefox Integration broken

Postby sleeper_service » 31 Oct 2016, 08:47

for what it's worth, I haven't seen any problem. v16.8 (3bba9c3) ff 49.0.2 on linux.

conrad784
Bear Rating Trainee
Bear Rating Trainee
Posts: 7
Joined: 30 Oct 2016, 23:54

Re: Firefox Integration broken

Postby conrad784 » 31 Oct 2016, 09:08

I've got 49.0.2 on ArchLinux - also broken for me.
So this might be an issue with my server configuration?

Is yours on a subdomain?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Firefox Integration broken

Postby fox » 31 Oct 2016, 09:45

works fine here, i'm afraid (latest firefox, windows)

could be something with PHP configuration (i.e. magic quotes), unlikely though, because tt-rss force disables this garbage

my tt-rss is in a subdirectory tho

conrad784
Bear Rating Trainee
Bear Rating Trainee
Posts: 7
Joined: 30 Oct 2016, 23:54

Re: Firefox Integration broken

Postby conrad784 » 31 Oct 2016, 09:55

fox wrote:looks like firefox does urlencode() on url twice for some reason, i wonder why [..]


good catch, I used a rewrite rule for https. So I changed the Integration in about:config to https, works like a charm! (maybe I should also look into what my rewrite rule does not catch right...)
Thanks :D

langhaarschneider
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 09 Feb 2015, 10:45

Re: Firefox Integration broken

Postby langhaarschneider » 07 Nov 2016, 17:42

conrad784 wrote:
fox wrote:looks like firefox does urlencode() on url twice for some reason, i wonder why [..]


good catch, I used a rewrite rule for https. So I changed the Integration in about:config to https, works like a charm! (maybe I should also look into what my rewrite rule does not catch right...)
Thanks :D


Could you please explain a bit more what you changed? i might have the same problem - but i don't understand which key you actually changed to which value...

conrad784
Bear Rating Trainee
Bear Rating Trainee
Posts: 7
Joined: 30 Oct 2016, 23:54

Re: Firefox Integration broken

Postby conrad784 » 07 Nov 2016, 19:31

You can see in my first post, the connection to your tt-rss is stored in an config value.
I changed the value to https://rss.***

This is only a problem because my rewrite rule (to rewrite all http calls to https) does evaluates the input and not the integrated function in tt-rss.
This is therefore only an issue if you wrote the rewrite rule like me.

langhaarschneider
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 09 Feb 2015, 10:45

Re: Firefox Integration broken

Postby langhaarschneider » 07 Nov 2016, 21:49

Thanks for your help - now i understand it - and that solution works for me to. Seems i have the same problems in my server config...

paulo.david
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 16 Dec 2016, 02:22

Re: Firefox Integration broken

Postby paulo.david » 19 Dec 2016, 19:34

For what it's worth, I had the same problem when I switched to https and solved it by using 'https://mysite.com' in SELF_URL_PATH, in config.php, instead of just http as previously.

conrad784
Bear Rating Trainee
Bear Rating Trainee
Posts: 7
Joined: 30 Oct 2016, 23:54

Re: Firefox Integration broken

Postby conrad784 » 20 Dec 2016, 13:44

or you use permanent redirect instead of rewrite rules


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests