Page 1 of 1

Firefox Integration broken

Posted: 31 Oct 2016, 00:32
by conrad784
Hi,

it's not a severe bug, but I noticed that the Firefox Integration is broken.

My tt-rss installation is on a subdomain: rss.*.de.
Latest git-version on Debian Jessie Stable with Apache2 + MariaDB.

Tested with FirefoxESR (45.4.0) and Development (51.0a2).
Both times with my usual profile and also a clean new profile.

I hope my pictures can help finding the bug.

Besides, nice work fox with tt-rss, using it a lot!
Conrad

Re: Firefox Integration broken

Posted: 31 Oct 2016, 08:06
by fox
looks like firefox does urlencode() on url twice for some reason, i wonder why

i'll take a look later today

Re: Firefox Integration broken

Posted: 31 Oct 2016, 08:47
by sleeper_service
for what it's worth, I haven't seen any problem. v16.8 (3bba9c3) ff 49.0.2 on linux.

Re: Firefox Integration broken

Posted: 31 Oct 2016, 09:08
by conrad784
I've got 49.0.2 on ArchLinux - also broken for me.
So this might be an issue with my server configuration?

Is yours on a subdomain?

Re: Firefox Integration broken

Posted: 31 Oct 2016, 09:45
by fox
works fine here, i'm afraid (latest firefox, windows)

could be something with PHP configuration (i.e. magic quotes), unlikely though, because tt-rss force disables this garbage

my tt-rss is in a subdirectory tho

Re: Firefox Integration broken

Posted: 31 Oct 2016, 09:55
by conrad784
fox wrote:looks like firefox does urlencode() on url twice for some reason, i wonder why [..]


good catch, I used a rewrite rule for https. So I changed the Integration in about:config to https, works like a charm! (maybe I should also look into what my rewrite rule does not catch right...)
Thanks :D

Re: Firefox Integration broken

Posted: 07 Nov 2016, 17:42
by langhaarschneider
conrad784 wrote:
fox wrote:looks like firefox does urlencode() on url twice for some reason, i wonder why [..]


good catch, I used a rewrite rule for https. So I changed the Integration in about:config to https, works like a charm! (maybe I should also look into what my rewrite rule does not catch right...)
Thanks :D


Could you please explain a bit more what you changed? i might have the same problem - but i don't understand which key you actually changed to which value...

Re: Firefox Integration broken

Posted: 07 Nov 2016, 19:31
by conrad784
You can see in my first post, the connection to your tt-rss is stored in an config value.
I changed the value to https://rss.***

This is only a problem because my rewrite rule (to rewrite all http calls to https) does evaluates the input and not the integrated function in tt-rss.
This is therefore only an issue if you wrote the rewrite rule like me.

Re: Firefox Integration broken

Posted: 07 Nov 2016, 21:49
by langhaarschneider
Thanks for your help - now i understand it - and that solution works for me to. Seems i have the same problems in my server config...

Re: Firefox Integration broken

Posted: 19 Dec 2016, 19:34
by paulo.david
For what it's worth, I had the same problem when I switched to https and solved it by using 'https://mysite.com' in SELF_URL_PATH, in config.php, instead of just http as previously.

Re: Firefox Integration broken

Posted: 20 Dec 2016, 13:44
by conrad784
or you use permanent redirect instead of rewrite rules