Feed has unread count, but no articles show up

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
imgx64
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Apr 2017, 14:48

Feed has unread count, but no articles show up

Postby imgx64 » 17 Apr 2017, 15:25

I am subscribed to this feed (http://feeds.arstechnica.com/arstechnica/index ), I can see that there are 49 unread articles, but when I open it, it just says "No articles found to display.". The Android client also shows the unread count but no articles show up when I open it.

The feed itself parses correctly with myfeedsucks and with the "f D" debugger.

Looking at nginx error.log, I see a bunch of errors about PostgreSQL that happened on 14 April, which is probably when the problem started. Some samples:

Code: Select all

PHP message: PHP Warning:  pg_last_error(): No PostgreSQL link opened yet in /var/www-nginx/tt-rss/classes/db/pgsql.php on line 24
PHP message: PHP Warning:  pg_connect(): Unable to connect to PostgreSQL server: FATAL:  the database system is in recovery mode in /var/www-nginx/tt-rss/classes/db/pgsql.php on line 21
PHP message: PHP Warning:  pg_last_error(): No PostgreSQL link opened yet in /var/www-nginx/tt-rss/classes/db/pgsql.php on line 24" while reading response header from upstream, client: 94.76.41.29, server: [redacted], request: "POST /tt-rss//api/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "[redacted]"
2017/04/14 13:57:11 [error] 210#210: *42639 FastCGI sent in stderr: "PHP message: PHP Warning:  pg_connect(): Unable to connect to PostgreSQL server: FATAL:  the database system is in recovery mode in /var/www-nginx/tt-rss/classes/db/pgsql.php on line 21


I'm guessing PostgreSQL crashed and corrupted the database somehow. Is there anything I can do or should I just export OPML and do a clean installation?

Installation details:
Tiny Tiny RSS v17.1 (b8f23d6), CentOS 7.3, PHP 5.4, PostgreSQL 9.2

Code: Select all

[[email protected] tt-rss]# git log -1 | head -1
commit b8f23d68484d8c0672d6c01a1344804dd5aba17f
[[email protected] tt-rss]# cat /etc/centos-release
CentOS Linux release 7.3.1611 (Core)
[[email protected] tt-rss]# rpm -qa | grep 'nginx\|postgres\|php' | sort
nginx-1.10.2-1.el7.ngx.x86_64
nginx-filesystem-1.10.2-1.el7.noarch
php-cli-5.4.16-42.el7.x86_64
php-common-5.4.16-42.el7.x86_64
php-fpm-5.4.16-42.el7.x86_64
php-mbstring-5.4.16-42.el7.x86_64
php-pdo-5.4.16-42.el7.x86_64
php-pgsql-5.4.16-42.el7.x86_64
php-theseer-fDOMDocument-1.6.0-2.el7.noarch
php-xml-5.4.16-42.el7.x86_64
postgresql-9.2.18-1.el7.x86_64
postgresql-libs-9.2.18-1.el7.x86_64
postgresql-server-9.2.18-1.el7.x86_64

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Feed has unread count, but no articles show up

Postby fox » 17 Apr 2017, 15:59

what happens if you set it to show all articles and click on a few so that counters update? either that or delete stuff from counters cache tables.

imgx64
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Apr 2017, 14:48

Re: Feed has unread count, but no articles show up

Postby imgx64 » 17 Apr 2017, 18:41

I set it to show All Articles, and no articles showed up in the Ars Technica page in TT-RSS. These 49 articles really exist in the RSS and I have not read them, but they're not showing up in TT-RSS. This database corruption even broke "All articles" and "Fresh articles" pages and nothing is showing up in them either. However, all other feeds are working correctly.

I think I'll just remove the broken feed and try to delete all its articles from the database and see if it fixes it.

imgx64
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Apr 2017, 14:48

Re: Feed has unread count, but no articles show up

Postby imgx64 » 17 Apr 2017, 19:50

Ok. My database is definitely hosed. Logging into PostgreSQL and just trying to select and delete some rows is giving me all sorts of weird errors that I have neither the time nor the expertise to fix (What on Earth is a "pg_toast"?). I'll just do a clean install. *shrug*

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Feed has unread count, but no articles show up

Postby fox » 17 Apr 2017, 20:04

sorry to hear that, i don't think i ever ran into a legit database corruption on pgsql :(

i do however have backups :v

imgx64
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 17 Apr 2017, 14:48

Re: Feed has unread count, but no articles show up

Postby imgx64 » 17 Apr 2017, 21:09

This VPS is only used for TT-RSS and I have OPML backups, so everything is alright.

But yes, PostgreSQL corruption is extremely rare, I wonder if my VPS provider is having hardware issues. :?


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests