Page 1 of 1

Login screen and some other questions...

Posted: 19 Mar 2012, 22:45
by vbmark
Hello,

The application installed flawlessly and is working great!

I am using my host provider's directory password protection feature to prevent unwanted visitors to my feeds. Is there a login screen that I should be getting? Is there a way to turn on a login screen? This is just for one, single user -- me.

Next, on the tab named "Linked" I get the following error...

Your access level is insufficient to open this tab.
Warning: Cannot modify header information - headers already sent by (output started at /home/blah/public_html/tt-rss/classes/pref_instances.php:13) in /home/blah/public_html/tt-rss/backend.php on line 164
{"error":{"code":7}}


Any tips on how to fix that?

Lastly, I am using tt-rss as a replacement for Google Reader as I migrate away from Google. Can someone recommend a good Google calendar replacement? So far everything I've looked at stinks.

Thanks!

Re: Login screen and some other questions...

Posted: 20 Mar 2012, 09:24
by fox
config.php, search for SINGLE_USER_MODE. Linked tab shouldn't fail like that though, this seems like a bug (should be fixed in trunk now).

Re: Login screen and some other questions...

Posted: 20 Mar 2012, 15:44
by vbmark
I already have SINGLE_USER_MODE' set as follows:

Code: Select all

define('SINGLE_USER_MODE', true);

I had it set that way from the beginning and have yet to see a login screen.

Also, since this is set as true:

Code: Select all

define('CHECK_FOR_NEW_VERSION', true);

will I automatically get the new version installed or will I just see a message somewhere informing me that I need to download and upgrade?

Thanks for the awesome code!

Re: Login screen and some other questions...

Posted: 20 Mar 2012, 16:46
by fox
I had it set that way from the beginning and have yet to see a login screen.


You need to set this to false to enable it.

will I automatically get the new version installed or will I just see a message somewhere informing me that I need to download and upgrade?


You'll get a prompt, installing is manual.

Re: Login screen and some other questions...

Posted: 20 Mar 2012, 17:14
by vbmark
Once I logged in as admin the "Linked" tab started working.

Thank you for your help.

Re: Login screen and some other questions...

Posted: 22 Apr 2013, 01:08
by lapsus63
Hi,

I'm new to ttss. I've just installed this version : tarball, v1.7.8 (Apr 04, 2013). I'm under Debian 6.0.
I had some problems after configuration with log-in form, having the same error as above (Error 7).

After testing solutions here is what happened :

1 - I toggled single user mode from false to true :
I switched from error 7 to a loading page blocked at 20% with unexpected error (with a white javascript window into the page)
2 - I have disabled php_apc (commenting ;extension=apc.so in /etc/php5/apache2/conf.d/apc.ini in my case)
Everything is fine now. I think there is a problem with apc.
3 - I switched back single user mode from true to false. It still working.

Another little bug :
In firefox, 20.0.1, the login form was showing a middle part (other login/pwd + submit components) between the login inputs and the submit button. Disabling apc seems to have repaired this strange behaviour too. Note that when switching tab this middle part disappeared.

Sorry for my weak english, I hope you understood my message :-)