Page 5 of 14

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 31 Mar 2013, 15:42
by JcTux
mboinet wrote:There's no need for this workaround anymore, there's a settings page where you can tune this between 1 and 60. Anything greater than 60 will be limited by the API.
This setting is saved between usages in LocalStorage.

:D

I did not noticed the 60 pages limitation.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 31 Mar 2013, 15:49
by fox
You can of course change it in classes/api.php. Just search for 60.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 31 Mar 2013, 16:01
by JcTux
fox wrote:You can of course change it in classes/api.php. Just search for 60.

Great !
Thanks, it works.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 31 Mar 2013, 23:07
by raindog469
mboinet wrote:@raindog469 thank you for the input :mrgreen: Did you compare on a cellular network? It's really the target I'm trying to optimize for.


Not as of yet, as the only cell service we get at home is a femtocell (very low power cell tower that routes voice and data over our cable modem). I'll try it this week when I'm out of the house and have some time to Connectbot into my server and swap the two versions of index.html repeatedly.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 01 Apr 2013, 05:31
by shentabla
mboinet wrote:
shentabla wrote:Thanks this is great.
I have a problem reading Japanese post titles. The content displays OK, but the titles display as "??????".
Hope you can update to fix this...
Thanks again

I'd need the RSS feed to reproduce this & have a look.


Here's an example Japanese feed:
http://santoorjimi.jugem.jp/?mode=atom

Here's an English language feed in which some characters are displaying wrongly:
http://fukushima-diary.com/feed/

Thanks

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 01 Apr 2013, 13:50
by mboinet
I've just done a quick test and can't see any post titles display problems on Firefox.

What browser are you using? Did you test on multiple ones?
Are you sure your Character Sets are well configured on your web server?

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 01 Apr 2013, 14:05
by shentabla
I'm on iOS, using Chrome. Just tested with Safari and Atomic Web Browser with the same results.
My web server is Dreamhost - I imagine their character sets are well configured, but don't know how to check.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 04 Apr 2013, 18:38
by HunterZ
Two issues have cropped up with new versions of tt-rss:


First: installing this to a direct subdirectory of tt-rss causes it to get wiped out by the auto updater plugin. I know this is relevant because some of us were installing to the mobile/ subdirectory, and the default config of ttrss-mobile uses a ttrss-mobile subdirectory as an example.

I'll be reinstalling to a sibling directory of my tt-rss install instead of a subdirectory. I suppose installing to plugins may also work, but it's not really a plugin.


Second: since the mobile browser detection code of tt-rss no longer redirects to the mobile/ subdirectory (which no longer exists anyways), tt-rss' mobile browser detection is now only useful for those who cling to the old mobile web interface (which is now implemented via an unsupported plugin), and ttrss-mobile users must now browse explicitly to the ttrss-mobile path.

To actually make the built-in tt-rss mobile browser detection routines useful for people who are using non-deprecated mobile web interfaces, it might be helpful if tt-rss could provide a configuration option to specify where mobile browsers should be redirected (e.g. the mobile plugin, or some path to ttrss-mobile, etc.).

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 04 Apr 2013, 19:21
by jonb
Hmmm... I copied the my mobile subdirectory from the backup back into the same subdirectory it was it before (reader.mydomain.com/mobile). When I go straight to that URL I get the login screen. When I try to log in, it gets hung up at "Authenticating..."

This worked on 1.7.5. What am I missing?

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 04 Apr 2013, 21:55
by lordofthemoon
Hmmm... I copied the my mobile subdirectory from the backup back into the same subdirectory it was it before (reader.mydomain.com/mobile). When I go straight to that URL I get the login screen. When I try to log in, it gets hung up at "Authenticating..."

I'm seeing the same thing.

I've put my mobile directory in the root of my web server and created a symlink in my TT-RSS directory called 'mobile' pointing to it. When I visit the page and login, I see the 'authenticating' message, it briefly goes to the 'categories' page but immediately switches back to the login page. Any ideass?

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 04 Apr 2013, 22:40
by mboinet
For the authentication hanging: it's a ttrss-mobile bug. It's been fixed last monday on Github.
A fresh copy should be the solution.

I stopped working on enhancements and I'm trying to do a proper 1.0 release with require.js usage & the code as tidy modules.
It should be easier to know when there are important fixes and new features.


As of mobile detection & redirection, I need to get in contact with fox and sort this out. But it's on a lower priority & I'm expecting to have less free time to work on this in the coming weeks.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 04 Apr 2013, 23:07
by HunterZ
mboinet wrote:As of mobile detection & redirection, I need to get in contact with fox and sort this out. But it's on a lower priority & I'm expecting to have less free time to work on this in the coming weeks.

No worries. You may want to toss a note into the readme to warn people against installing in a subdirectory of tt-rss, though.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 04 Apr 2013, 23:24
by mboinet
Good idea, it can prevent support requests: commit

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 05 Apr 2013, 03:35
by jonb
For the authentication hanging: it's a ttrss-mobile bug. It's been fixed last monday on Github.
A fresh copy should be the solution.


Still having the problem running 1.7.8.

Re: Mobile webapp for TT RSS: ttrss-mobile

Posted: 05 Apr 2013, 05:40
by jonb
Sorry -- Should have said that I'm running 1.7.8, but that I also grabbed the latest zip file at https://github.com/mboinet/ttrss-mobile and I'm still having the hanging authenticating problem.