Error in getArticle

Development-related discussion, including bundled plugins
rockdreamer
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 15 May 2013, 18:35

Error in getArticle

Postby rockdreamer » 15 May 2013, 18:54

Hi, I'm preparing a C# API for tt-rss (mostly for my own educational purposes and because I own a WP7.8 device).

I'm getting an error when calling the getArticle api.

post data is

Code: Select all

{"op":"getArticle","sid":"ebkbobaf0doloov1u2mj84ont3","seq":2,"article_ids":"100","response":null}


The response I get is:

Code: Select all

Query <i>SELECT id,title,link,content,cached_content,feed_id,comments,int_id,
         marked,unread,published,
         SUBSTRING(updated,1,16) as updated,
         author
         FROM ttrss_entries,ttrss_user_entries
         WHERE   id IN () AND ref_id = id AND owner_uid = 2</i> failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND ref_id = id AND owner_uid = 2' at line 6


It looks like the article_ids are not passed to the query.
According to the api documentation getArticle:
Requests JSON-encoded article object with specific ID.

article_id (integer) - article ID to return as of 15.10.2010 git or 1.5.0 supports comma-separated list of IDs
Since 1.4.3 also returns article attachments.

what is the proper way of encoding article_ids with comma? Thanks :)

rockdreamer
Bear Rating Trainee
Bear Rating Trainee
Posts: 5
Joined: 15 May 2013, 18:35

Re: Error in getArticle

Postby rockdreamer » 15 May 2013, 20:32

my bad, I just noticed I was sending the wrong parameter name (article_ids instead of article_id).

I'll publish the API as soon as I get all unit tests rolling


Return to “Development”

Who is online

Users browsing this forum: No registered users and 1 guest