Centos 6.4 and setsebool

Howtos, instructions and links to related software. Do not ask questions here.
cgrobaus
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 15 Sep 2013, 17:00

Centos 6.4 and setsebool

Postby cgrobaus » 15 Sep 2013, 17:31

First of all, thanks for what looks like a great product. I am looking forward to using tt-rss. I just wanted to share one command I had to run on my centos 6.4 installation to allow tt-rss to communicate with the postgresql database I set up.

I had already configured postgresql.conf, pg_hba.conf, and firewall settings for remote access. I was confused to find I could not connect from the php install page with the user/passwd I created in psql, but I could connect from the command line via psql with the hostname option.

Eventually I found that there was an SELinux setting blocking my connection; I thought I'd post this in case others are having the same issue.

Description:
You have already:

1) Configured postgresql.conf to set listen_addresses
2) Configured pg_hba.conf to add a host row for md5 validation.
3) Opened port 5432 in your firewall
4) Created a role/user with a password in your database cluster
5) You can connect to the database you created with "psql -h yourserver -U youruser -d yourdatabase" with your password.

Solution:

Try the following command to see if selinux is enabled.

#grep enforcing /etc/selinux/config

If you see SELINUX=enforcing, then you can run the following command to make sure that httpd can connect to databases over the network.

#/usr/sbin/setsebool -P httpd_can_network_connect_db 1

Return to “Knowledge Base”

Who is online

Users browsing this forum: No registered users and 2 guests