Page 3 of 5

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 04 Apr 2013, 14:56
by fox
I'll update the first post with those two zips for the time being. :)

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 04 Apr 2013, 19:49
by ebell451
Updated the favicon for Twitter if anyone is interested :D

Edit: corrected png file

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 05 Apr 2013, 14:14
by Andyt8
@ebell451: in your zip is a faulty picture included. I downloaded it several times and after unzip, I'm not able to open the picture.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 06 Apr 2013, 09:37
by ebell451
@Andyt8: my apologies. Try again as the file format has been corrected in the original post above.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 08 Apr 2013, 10:16
by Andyt8
Your new package is OK, thanks for the icon.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 10 Apr 2013, 00:42
by deckyon
Tried sending an article to Pintrest with the plugin. I was successfully logged into Pintrest (it showed my own boards) and got the following error dialog box: "You need to upload an image or provide the 'image_url' parameter."

I am running the latest version of the software and the plugin.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 23 Apr 2013, 11:25
by Andyt8
fox wrote:They are now available from a separate contrib repository at Github:

...

Version 1.7.9: https://github.com/gothfox/Tiny-Tiny-RSS-Contrib


It seems to me, there is a mistake in your Googleplus plugin
https://github.com/gothfox/Tiny-Tiny-RS ... s/init.php
in line 35...

Code: Select all

      $id = db_escape_string($this->link, $_REQUEST['id']);


should be

Code: Select all

      $id = db_escape_string($_REQUEST['id']);

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 23 Apr 2013, 12:07
by fox
Thanks, fixed.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 23 Apr 2013, 23:23
by ardichoke
When using the Google Plus, Pinterest or Pocket plugins from this, the popup hangs on "Loading, please wait" and I get the following errors in my log. This is running on 1.7.9, with MariaDB 5.3 and PHP 5.3. Plugins were installed from a fresh pull from github as of an hour ago. (Note: I haven't tried any other plugins from this set, also the log snippet has been sanitized)

Code: Select all

[Tue Apr 23 15:12:13 2013] [warn] [client -] mod_fcgid: stderr: PHP Warning:  mysql_real_escape_string() expects parameter 2 to be resource, null given in tt-rss/include/db.php on line 50, referer: https://domain.info/tt-rss/
[Tue Apr 23 15:12:13 2013] [warn] [client -] mod_fcgid: stderr: PHP Warning:  Missing argument 2 for db_query(), called in tt-rss/plugins/googleplus/init.php on line 39 and defined in tt-rss/include/db.php on line 54, referer: https://domain.info/tt-rss/
[Tue Apr 23 15:12:13 2013] [warn] [client -] mod_fcgid: stderr: PHP Warning:  mysql_query() expects parameter 2 to be resource, string given in tt-rss/include/db.php on line 65, referer: https://domain.info/tt-rss/
[Tue Apr 23 15:12:13 2013] [warn] [client -] mod_fcgid: stderr: PHP Warning:  mysql_error() expects parameter 1 to be resource, string given in tt-rss/include/db.php on line 69, referer: https://domain.info/tt-rss/

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 23 Apr 2013, 23:35
by fox
>This is running on 1.7.9

No you are not.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 23 Apr 2013, 23:38
by ardichoke
fox wrote:>This is running on 1.7.9

No you are not.


Wow... I blame not enough coffee. Sorry to waste your time.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 08 May 2013, 18:59
by Centinel
I'm trying to set up an instance of Tiny Tiny RSS 1.7.8 on CentOS 5.9. The Google+, Twitter, and Pinterest plugins don't show up after I enable them.

I grabbed the latest versions from the 1.7.8 tree and there shouldn't be any problem with permissions, so I'm not sure what the problem could be. Any ideas?

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 13 May 2013, 15:47
by bmar
after upgrading tt-rss to 1.7.9 and updating googleplus plugin from git got a:
"May 13 15:40:38 xxx php-cgi: [tt-rss] E_WARNING (2) (lib/phpqrcode/phpqrcode.php:946) Cannot modify header information - headers already sent by (output started at /usr/share/tt-rss/www/plugins/googleplus/init.php:567)
May 13 15:41:39 xxx php-cgi: [tt-rss] E_WARNING (2) (index.php:50) Cannot modify header information - headers already sent by (output started at /usr/share/tt-rss/www/plugins/googleplus/init.php:567)
May 13 15:41:41 xxx php-cgi: [tt-rss] E_WARNING (2) (backend.php:144) Cannot modify header information - headers already sent by (output started at /usr/share/tt-rss/www/plugins/googleplus/init.php:567)"

without that plugin - all works fine and I'd say faster then previous version.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 13 May 2013, 16:02
by fox
Most probably you screwed init.php somehow by adding a blank line before or after <?php ... ?> tags.

Re: pinterest, owncloud, pocket, tweet, etc social plugins

Posted: 13 May 2013, 16:08
by bmar
thanks, it's right... sorry for a dumb post :)