Page 1 of 1

All feeds fail to update with "Unknown/unsupported feed type"

Posted: 28 Feb 2017, 21:41
by flagarby
I've installed tt-rss on an Illumos-based platform (SmartOS) using a fresh git checkout (e6d66fe5), PHP 7.0, and postgres. It's configured and the webui is working fine, but every feed update fails with "Unknown/unsupported feed type". I've verified the PHP path is properly set in config.php.

Example:

Code: Select all

$ php ./update.php --debug-feed 1 --force-refetch --force-rehash
[18:37:05/81534] Lock: update.lock
[18:37:05/81534] start
[18:37:05/81534] local cache will not be used for this feed
[18:37:05/81534] fetching [http://tt-rss.org/forum/rss.php]...
[18:37:06/81534] fetch done.
[18:37:06/81534] saving cache/simplepie/be8fe7d3377d7b6a4f80b1df91f6bd63b477734e.xml
[18:37:06/81534] fetch error: Unknown/unsupported feed type
[18:37:06/81534] done


The cached file appears fine but the parsing is failing for some reason. Looks like a PATH issue, but I assumed setting 'PHP_EXECUTABLE' in the config would handle this.

Re: All feeds fail to update with "Unknown/unsupported feed type"

Posted: 28 Feb 2017, 22:00
by fox
>Illumos-based platform (SmartOS)

moving to unsupported because i don't even want to know what that is

>The cached file appears fine but the parsing is failing for some reason. Looks like a PATH issue,

i'm not sure what gave you an idea that this has anything to do with paths, actually this error is generated by the feed parser when the XML root element is of a wrong (i.e. unsupported) type. i'm going to assume either network or libxml-related issue.

e: for starters post that file that appears fine here.

Re: All feeds fail to update with "Unknown/unsupported feed type"

Posted: 28 Feb 2017, 22:30
by sleeper_service
it's based on solaris... which I run.

Re: All feeds fail to update with "Unknown/unsupported feed type"

Posted: 28 Feb 2017, 22:43
by flagarby
i'm going to assume either network or libxml-related issue

Doesn't look like network as the cached file looks as I'd expect:

Code: Select all

$ cat cache/simplepie/be8fe7d3377d7b6a4f80b1df91f6bd63b477734e.xml
<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" media="screen" href="/~d/styles/atom10full.xsl"?><?xml-stylesheet type="text/css" media="screen" href="http://feeds.feedburner.com/~d/styles/itemcontent.css"?><feed xmlns="http://www.w3.org/2005/Atom" xmlns:feedburner="http://rssnamespace.org/feedburner/ext/1.0" xml:lang="en-gb">


<title>Tiny Tiny RSS</title>
<subtitle>Community Forums</subtitle>
<link href="https://tt-rss.org/forum/index.php" />
<updated>2017-02-28T14:05:12+03:00</updated>

<author><name><![CDATA[Tiny Tiny RSS]]></name></author>
<id>https://tt-rss.org/forum/feed.php</id>
<atom10:link xmlns:atom10="http://www.w3.org/2005/Atom" rel="self" type="application/atom+xml" href="http://feeds.feedburner.com/tt-rss-forum" /><feedburner:info uri="tt-rss-forum" /><atom10:link xmlns:atom10="http://www.w3.org/2005/Atom" rel="hub" href="http://pubsubhubbub.appspot.com/" /><feedburner:browserFriendly></feedburner:browserFriendly><entry>
<author><name><![CDATA[diffuser]]></name></author>
...


As for libxml, it's been compiled with XML support. Do the listed versions look reasonable?:

Code: Select all

$ php -i | grep -i libxml
libxml Version => 2.9.4
libXML support => active
libXML Compiled Version => 2.9.4
libXML Loaded Version => 20904
libXML streams => enabled
libxml2 Version => 2.9.4

Re: All feeds fail to update with "Unknown/unsupported feed type"

Posted: 28 Feb 2017, 22:59
by flagarby
This was a problem with my PHP config. It looks like it was loading the PHP extensions twice and breaking something along the way. All working just fine now. Thanks for the attention either way.

Re: All feeds fail to update with "Unknown/unsupported feed type"

Posted: 01 Mar 2017, 00:18
by sleeper_service
that would have been my guess.