Page 1 of 1

Problem with plurals in translation files

Posted: 10 Apr 2013, 15:44
by davidm
I'm using Poedit for translation. It complains about plurals when saving the edited .po file, and corrupts the file if I actually edit those strings (it claims to have plural support). I edited them with a text editor.

This is the log from Poedit:

Code: Select all

messages.po:501: message catalog has plural form translations...
messages.po:7: ...but header entry lacks a "plural=EXPRESSION" attribute
messages.po:501: message catalog has plural form translations...
messages.po:7: ...but header entry lacks a "nplurals=INTEGER" attribute


Is this Poedit's bug, or tt-rss'?

PS: I couldn't find a way to register for the bugtracker.

Re: Problem with plurals in translation files

Posted: 10 Apr 2013, 16:08
by blainemono
Let me get this straight.

You are using a third party program, reading said program's log, then wondering whether it is a tt-rss bug or not?

Okaaaaay

Re: Problem with plurals in translation files

Posted: 10 Apr 2013, 16:21
by fox
davidm,

Well the .po file could have a malformed header because of a previous translator or something, you could fix it so it would work properly and resubmit everything back.

Re: Problem with plurals in translation files

Posted: 10 Apr 2013, 17:15
by davidm
fox wrote:davidm,

Well the .po file could have a malformed header because of a previous translator or something, you could fix it so it would work properly and resubmit everything back.


Ok, I'll try that. I wrongly assumed that it was some kind of centrally generated setting, same for every language. I'll try to discover the right configuration for Spanish.


blainemono: Yeah, when a specialized third party program says that the file in tt-rss is malformed, which it actually is, I report in tt-rss. Doing the contrary would be like getting a malformed feed log from tt-rss and reporting it here, instead of the original site. Exotic, I know. We surely have different ideas of straightness.

Re: Problem with plurals in translation files

Posted: 11 Apr 2013, 01:23
by dingoe
I had this too with the Dutch po file. Just enter "nplurals=2; plural=(n != 1);" in the plural form textbox of catalogue properties.