A couple of suggestions related to "mark as read" and autoload.

Request new functionality here
CptanPanic
Bear Rating Trainee
Bear Rating Trainee
Posts: 8
Joined: 08 Dec 2016, 16:03

A couple of suggestions related to "mark as read" and autoload.

Postby CptanPanic » 03 Apr 2017, 15:39

I tend to read my feeds in Fresh or All articles, and if I just scroll through them everything works fine in regards to autoload. But if I use the Mark feed as read button, things don't behave as nicely.

1) It would be nice if when pressing mark as read button, then page would automatically load in some new feeds to fill screen. Currently if you mark all the feeds as read on page, then although no articles are currently displayed, you have to scroll down to get autoload articles from other feed.
2) Sometimes because of #1 doesn't happen, you end up with just half a feed displayed when you scroll down to it, and now you can only see half a feed, but if you click mark feed as read then all the articles are marked as read.

Thanks.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: A couple of suggestions related to "mark as read" and autoload.

Postby fox » 04 Apr 2017, 15:05

your post is kinda hard to figure out, maybe you should post some screenshots, because i'm honestly not sure wtf you're actually doing with the UI.

that said, when you press "mark as read" button (the one at top right) active feed is refreshed and new headlines are loaded. nothing new is loaded when you mark *selection* as read because that would be incredibly annoying.

if your tt-rss installation of which you decided not to share any useful information whatsoever behaves differently, well, idk.

CptanPanic
Bear Rating Trainee
Bear Rating Trainee
Posts: 8
Joined: 08 Dec 2016, 16:03

Re: A couple of suggestions related to "mark as read" and autoload.

Postby CptanPanic » 04 Apr 2017, 17:01

Ok see my 2 pictures I attached. Image 1.png shows fresh articles page, with full page of articles. 2.png shows same page, but after I clicked "mark feed as read" a few times. Notice that it does say "loading, please wait" but will not actually load any new articles until I scroll down.
Attachments
2.png
2.png (116.12 KiB) Viewed 2321 times
1.PNG
1.PNG (197.53 KiB) Viewed 2321 times

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: A couple of suggestions related to "mark as read" and autoload.

Postby fox » 04 Apr 2017, 17:56

>although no articles are currently displayed

???

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: A couple of suggestions related to "mark as read" and autoload.

Postby fox » 05 Apr 2017, 13:17

anyway, i poked around a bit, and i can't reproduce the situation of "loading..." prompt being stuck visible with no content appearing (or the prompt disappearing if there's nothing to load). you might want to investigate browser console for possible errors/timeouts.


Return to “Feature requests”

Who is online

Users browsing this forum: No registered users and 2 guests