Page 1 of 1

Update daemon is not updating feeds

Posted: 28 Oct 2010, 11:07
by mimox
Since yesterday, I did not get any new feeds. There is some error box at the top of the screen "Update daemon is not updating feeds" and this is the whole error message:

---
Update daemon is taking too long to perform a feed update. This could indicate a problem like crash or a hang. Please check the daemon process or contact instance owner.

Last update: 2010.10.27, 10:48
---

Re: Update daemon is not updating feeds

Posted: 28 Oct 2010, 11:13
by Hypernova
I have the same error. Is this the downtime in the sticky thread?

Re: Update daemon is not updating feeds

Posted: 28 Oct 2010, 11:51
by fox
Nope, that was just daemon being stuck. I have also merged the latest trunk and updating the schema seems to be taking a while, so hang on tight.

Re: Update daemon is not updating feeds

Posted: 28 Oct 2010, 12:04
by fox
Looks like it works now.

Re: Update daemon is not updating feeds

Posted: 29 Oct 2010, 00:45
by mimox
fox wrote:Looks like it works now.


It used to... but now I have not gotten any new items for hours. No error message either but there's still something not right I think...

Re: Update daemon is not updating feeds

Posted: 29 Oct 2010, 07:11
by Hypernova
Exactly the same situation as mimox: It works this morning, then at some point stop working again.

Thanks for the info, fox.

Re: Update daemon is not updating feeds

Posted: 29 Oct 2010, 09:27
by fox
Dunno, it looked like it was working. Well, I have restarted it, let's see how it goes.

Re: Update daemon is not updating feeds

Posted: 29 Oct 2010, 10:03
by futtta
same here, no myriad of mashable articles that normally pour in over the night :)

Re: Update daemon is not updating feeds

Posted: 29 Oct 2010, 10:06
by futtta
should've posted this earlier, updated are pooring in! :D

Re: Update daemon is not updating feeds

Posted: 29 Oct 2010, 14:35
by fox
Found one more feed which seems to hang the daemon for some reason: http://www.netzpolitik.org/feed/

Re: Update daemon is not updating feeds

Posted: 01 Nov 2010, 20:28
by futtta
the daemon seems to be hanging again?

Re: Update daemon is not updating feeds

Posted: 01 Nov 2010, 20:55
by fox
Looks like it works to me.

I'd like to note that "omg I had no stuff for the last hour" is probably not the best reason to start the alarms. There's a lot of users and only 2 update processes running, stuff can take a while.

Re: Update daemon is not updating feeds

Posted: 01 Nov 2010, 21:03
by futtta
weird, i do see the "Update daemon is not running" error message. i'll try reloading the entire page.

Re: Update daemon is not updating feeds

Posted: 01 Nov 2010, 23:26
by fox
Ah, right. Looks like this one cleanup script I have added yesterday happily erased daemon's lockfile, it was actually running though. Should be fixed now. :)