Trouble updating tt-rss

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Trouble updating tt-rss

Postby oliroe » 27 May 2013, 22:46

Hi all

Hoped one of you may be able to help me with a problem I have updating tt-rss to the new version. The plugin has successfully been loaded but I get the following error message

Work directory: /volume1/web/tt-rss
Both tt-rss and parent directories should be writable as current user (nobody).

Don't suppose anyone could help a noob sort one of my final issues out?

Thanks in advance
Attachments
Capture.PNG
Capture.PNG (11 KiB) Viewed 4072 times

lotrfan
Bear Rating Disaster
Bear Rating Disaster
Posts: 73
Joined: 18 Mar 2013, 04:42

Re: Trouble updating tt-rss

Postby lotrfan » 27 May 2013, 23:16

Sounds like a permissions issue...
Run

Code: Select all

chown -R nobody /volume1/web

as root to change the owner to the user nobody. (the command could take awhile... it changes ownership recursively)

Alternatively,

Code: Select all

chmod 0777 /volume1/web

to set world-write permissions... it's not as secure, though.

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: Trouble updating tt-rss

Postby feader » 28 May 2013, 00:52

What lotrfan said. An even better solution is to install the trunk version with git. I suppose that you have a Synology NAS, a git version with install instructions is available here, and for the git instructions, there are some entries in this forum.

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: Trouble updating tt-rss

Postby oliroe » 28 May 2013, 03:34

Love this forum, replies are quick and friendly. That tip worked nicely but now have another error message

uploadfromtaptalk1369697566247.jpg
uploadfromtaptalk1369697566247.jpg (33.62 KiB) Viewed 3951 times


I am indeed running it from a symbology NAS, everything working well bar this and the fact my NAS no longer sleeps

Sent from my Galaxy Nexus using Tapatalk 2

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: Trouble updating tt-rss

Postby feader » 28 May 2013, 04:13

oliroe wrote:Love this forum, replies are quick and friendly.

Uhm.
Image

oliroe wrote:That tip worked nicely but now have another error message

That's hard to diagnose from afar without more information. My first guess would be a problem with the PHP safe mode (you can turn it off in the DSM control panel under "Web Services" or a similar named entry), but maybe … could you tell us what version of ttRSS you are running right now? There was a bug that prevented the detection of tar on a DS in earlier versions.

lotrfan
Bear Rating Disaster
Bear Rating Disaster
Posts: 73
Joined: 18 Mar 2013, 04:42

Re: Trouble updating tt-rss

Postby lotrfan » 28 May 2013, 04:23

What feader said...

Also check (and post, please) the output of

Code: Select all

which tar


Alternatively, as feader mentioned, updating via git is also a very nice method. You can also keep track (and preserve) your local changes. If you are debating on using git, know that you don't have to run trunk -- you can use it to update to the "stable" releases, too.

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: Trouble updating tt-rss

Postby oliroe » 28 May 2013, 04:27

Seems a case of one step forward, two steps back. Was on version 1.7.8 and disabled PHP safe mode. Upgrade seems to happen successfully but faced with this when trying to login

uploadfromtaptalk1369700863068.jpg
uploadfromtaptalk1369700863068.jpg (75.27 KiB) Viewed 3915 times


Sent from my Galaxy Nexus using Tapatalk 2

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Trouble updating tt-rss

Postby sleeper_service » 28 May 2013, 04:41

um, did you actually even *look* at the things in the screenshot you posted *before* you posted it?

lotrfan
Bear Rating Disaster
Bear Rating Disaster
Posts: 73
Joined: 18 Mar 2013, 04:42

Re: Trouble updating tt-rss

Postby lotrfan » 28 May 2013, 04:42

There were some config changes that happened between 1.7.8 and 1.7.9... I'm not sure why the config version wasn't bumped.. It's probably easiest to:
* backup your current config.php
* copy config.php-dist to config.php
* update the new config.php

You can also manually merge the changes made.

For a quick fix, add

Code: Select all

   define('FEED_CRYPT_KEY', '');
   // Key used for encryption of passwords for password-protected feeds
   // in the database. A string of 24 random characters. If left blank, encryption
   // is not used. Requires mcrypt functions.
   // Warning: changing this key will make your stored feed passwords impossible
   // to decrypt.

   define('SPHINX_SERVER', 'localhost:9312');
   // Hostname:port combination for the Sphinx server.

   define('SMTP_SERVER', '');
   // Hostname:port combination to send outgoing mail (i.e. localhost:25).
   // Blank - use system MTA.
   
   define('LOG_DESTINATION', 'sql');
   // Log destination to use. Possible values: sql (uses internal logging
   // you can read in Preferences -> System), syslog - logs to system log.
   // Setting this to blank uses PHP logging (usually to http server
   // error.log).

to config.php

If you use the email digest feature, the settings for that changed from SMTP_HOST and SMTP_PORT to SMTP_SERVER ("host:port" form).

Also, what sleeper_service said.

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: Trouble updating tt-rss

Postby oliroe » 28 May 2013, 05:04

Back up and running, many thanks for your help.

Apologies for not being able to solve it myself but only used ssh for the first time 4 days ago and have no programming or Linux experience.

At least I now know how to edit files using ssh and vi so I'll try not to waste anyone's time

Thanks again

Sent from my Galaxy Nexus using Tapatalk 2

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: Trouble updating tt-rss

Postby oliroe » 28 May 2013, 05:08

feader wrote:What lotrfan said. An even better solution is to install the trunk version with git. I suppose that you have a Synology NAS, a git version with install instructions is available here, and for the git instructions, there are some entries in this forum.


By the way this is the route I came from but only gets you to version 1.7.8.3. It's also the reason why I've managed to get this far without even knowing how to access my NAS through a shell

Sent from my Galaxy Nexus using Tapatalk 2

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Trouble updating tt-rss

Postby sleeper_service » 28 May 2013, 05:42

oliroe wrote:At least I now know how to edit files using ssh and vi so I'll try not to waste anyone's time


you were doing fine until you posted a screenshot that actually had the instructions on how to fix your problem.

always *look* at the error messages carefully and see if they make any sense to you... those, you'll admit, were pretty clear.

you'll almost always have to update the config.php from config.php-dist on upgrades. if you have access to the diff and patch programs, they'll make your life easier.

oliroe
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 24 May 2013, 02:27

Re: Trouble updating tt-rss

Postby oliroe » 28 May 2013, 05:59

That's a fair point, I'll read more closely in future. Thanks for the pointers

Sent from my Galaxy Nexus using Tapatalk 2


Return to “Support”

Who is online

Users browsing this forum: No registered users and 5 guests