Label Number and Article Count Not Matching

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Label Number and Article Count Not Matching

Postby blainemono » 01 Jul 2013, 16:35

tjh wrote:I'll now nip out the back and punch myself a few times, as per protocol.


Aw come on guy, the protocol at this point is to start ranting about how myisam support should be implemented right now because it's popular also because you can't and should not be bothered with minor technical details such as these.

Honest mistakes are no fun at all =(

User avatar
tjh
Bear Rating Trainee
Bear Rating Trainee
Posts: 11
Joined: 04 Apr 2013, 01:17
Location: Napier, New Zealand
Contact:

Re: Label Number and Article Count Not Matching

Postby tjh » 02 Jul 2013, 02:22

Final update on this, in case anyone else is silly enough to do what I did.

Just changing all the tables from myisam to innodb doesn't work. I still encountered the same issue.
I just blew away the database and started again.

Now it's working great.

Thanks for the assistance everyone, I hope this helps anyone else silly enough to do what I did (I'm amazed it worked for so long without me realizing)

User avatar
recognitium
Bear Rating Trainee
Bear Rating Trainee
Posts: 14
Joined: 02 Jul 2013, 01:35

Re: Label Number and Article Count Not Matching

Postby recognitium » 12 Jul 2013, 13:40

fox wrote:
tjh wrote:I am using MYISAM as my database type. I had no idea it would cause these problems.


There is no point in raging but your database *is* properly fucked. Your best best is exporting your opml and starting from scratch on innodb.

Edit: are you sure though? I think you need to modify the schema to import stuff as myisam, as it does explicitly set engine=innodb for tables.


I suspect I have some problems related to this. I checked my tables, and all were InnoDB, except for ttrss_cat_counters_cache, ttrss_counters_cache and ttrss_feedbrowser_cache . That was because accidentaly my MySQL server had MYISAM as the default engine. Could it be that these tables are created "on the go" and not explicitly with InnoDB?

If I convert them or delete them after the server has got InnoDB as default will TT-RSS regenerate them properly ?

Thanks in advance for helping this second technically-inapt-but-willing-to-learn newbie.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Label Number and Article Count Not Matching

Postby fox » 12 Jul 2013, 14:16

That tables are fine if they are isam, don't worry about it.

User avatar
recognitium
Bear Rating Trainee
Bear Rating Trainee
Posts: 14
Joined: 02 Jul 2013, 01:35

Re: Label Number and Article Count Not Matching

Postby recognitium » 12 Jul 2013, 15:06

fox wrote:That tables are fine if they are isam, don't worry about it.


thanks for the quick reply


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests