Bad encoding with some feeds

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
trantorian
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 15 Feb 2017, 19:55

Bad encoding with some feeds

Postby trantorian » 15 Feb 2017, 20:00

Hi guys,
I am experiencing problems with some feeds, like http://politico.eu/rss, which are parsed but return some encoding problems. Here an example of the text that I get:
BERLIN — As U.S. President Donald Trump’s economic world order dawns, Germany has formed a peculiar alliance with China to defend free trade.
The partnership is partly intended to signal to Washington that, in the face of the White House’s rising economic nationalism, deals without the U.S. will become more important, shrinking its influence on the global stage.

https://fakecake.org/myfeedsucks/ returns the same problem. It's the same with the Android app, too.

Do you have any idea about the motivation?
Thank you in advance!

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Bad encoding with some feeds

Postby fox » 16 Feb 2017, 00:05

as far as i can see whatever generated this feed either misuses html entities, has double-encoding problems or something like that.

Image

whatever is being sent here is being parsed properly, that's pretty much all there is to it. as to the motivation, i can only suggest you ask whoever is responsible for the site.

trantorian
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 15 Feb 2017, 19:55

Re: Bad encoding with some feeds

Postby trantorian » 16 Feb 2017, 12:19

Good to know that it is not a problem of the parser. I'll try to let them know.
Thanks a lot!


Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests