My feed doesn't parse properly, or does it?

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

My feed doesn't parse properly, or does it?

Postby fox » 30 Apr 2014, 13:46

Since this problem arises from time to time, I decided to make a simple page which shows how tt-rss will process any given feed. It is available here:

https://fakecake.org/myfeedsucks/

This way you can see whether latest tt-rss trunk parser will accept the problematic feed while excluding potential configuration or network-related problems on your end.

Have fun.

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: My feed doesn't parse properly, or does it?

Postby feader » 30 Apr 2014, 16:08

That's a good idea. Maybe you also could link to this in the FAQ? Not that I believe many will take notice :roll:

BTW: Is it possible to have a link to the FAQ in the forum header, next to where the link to the board software FAQ currently resides (or anywhere up there)? I've never seen that on any forum, but if it was there, we would have so much more reasons to yell at people for not reading before asking. :mrgreen:

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: My feed doesn't parse properly, or does it?

Postby fox » 30 Apr 2014, 17:15

I'm sure it's easy to hack phpbb to display whatever but nobody is going to read it anyway :)

Latimer
Bear Rating Master
Bear Rating Master
Posts: 131
Joined: 17 Mar 2013, 19:35

Re: My feed doesn't parse properly, or does it?

Postby Latimer » 30 Apr 2014, 17:56

My feed at http://www.e1.ru/news/rdf/full_img.xml sucks. When I'm trying to test it, the "Here's what we received" text area is rendered empty.

(The feed unironically sucks. I have no idea how to fix their encoding, and I was hoping to see what they actually feed into tt-rss)

e: great idea, thanks!

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: My feed doesn't parse properly, or does it?

Postby fox » 30 Apr 2014, 18:21

I dunno why is the textarea empty when the feed parses even though encoding is incorrect. Strange.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: My feed doesn't parse properly, or does it?

Postby fox » 30 Apr 2014, 19:16

fixed the encoding issues

Latimer
Bear Rating Master
Bear Rating Master
Posts: 131
Joined: 17 Mar 2013, 19:35

Re: My feed doesn't parse properly, or does it?

Postby Latimer » 30 Apr 2014, 20:52

Thanks!

Exagone313
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 06 Jan 2016, 14:38

Re: My feed doesn't parse properly, or does it?

Postby Exagone313 » 06 Jan 2016, 14:41

I have a problem on a feed, they used & instead of &. What can I do instead of contacting the website - I mean in tt-rss?

User avatar
morphus
SUSPENDED_USERS
SUSPENDED_USERS
Posts: 2
Joined: 19 Apr 2017, 17:27

Re: My feed doesn't parse properly, or does it?

Postby morphus » 19 Apr 2017, 19:23

My feed sucks agrees that my tt-rss feed (http://myreader.dailybrood.com/index.ph ... 76d32358f9) doesn't parse property. Using Tiny Tiny RSS v17.1 (b8f23d6) in a linux x86_64 shared hosted environment, mysql 5.6.35, php 5.6.30, and apache 2.4.25.

I've read instructions on how to show debug info. Just not sure where, when, or how to use 'f D' to enter update.php --debug info.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: My feed doesn't parse properly, or does it?

Postby fox » 19 Apr 2017, 20:44

your feed has a broken URL (index.php/public.php wtf is this?) maybe you should fix SELF_URL_PATH, idk

linoth
Bear Rating Trainee
Bear Rating Trainee
Posts: 22
Joined: 15 May 2013, 11:34

Re: My feed doesn't parse properly, or does it?

Postby linoth » 19 Apr 2017, 21:38

[quote="morphus"]My feed sucks agrees that my tt-rss feed (http://myreader.dailybrood.com/index.ph ... 76d32358f9) doesn't parse property. Using Tiny Tiny RSS v17.1 (b8f23d6) in a linux x86_64 shared hosted environment, mysql 5.6.35, php 5.6.30, and apache 2.4.25.

I've read instructions on how to show debug info. Just not sure where, when, or how to use 'f D' to enter update.php --debug info.
Basic troubleshooting, dude. Open the URL in a browser, what does it load?

Well, looks like a TTRSS login prompt. Yep, that's not a feed, that won't parse.

fox is right, your URL contains an error, http://myreader.dailybrood.com/public.p ... 76d32358f9 (removed index.php) seems to show up just fine. And surprise, TTRSS can parse a feed it generates just fine.