[git] Mobile site not working?

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
miqrogroove
Bear Rating Trainee
Bear Rating Trainee
Posts: 39
Joined: 20 Mar 2013, 02:08

Re: [git] Mobile site not working?

Postby miqrogroove » 24 Mar 2013, 02:34

j0nson, your mobile app doesn't work for me either. It fixes the 404 error and I can log in, but then all it says is Fresh Feed on one line and then No New Articles on the next line. I can't see any of my feeds or articles.

This is all sketchy as hell.

p.s. PHP Warning: Invalid argument supplied for foreach() in /mobile/index.php on line 398

j0nson
Bear Rating Trainee
Bear Rating Trainee
Posts: 21
Joined: 16 Mar 2013, 04:41

Re: [git] Mobile site not working?

Postby j0nson » 24 Mar 2013, 03:13

I can't decide whether I should be a dick because you're being a dick, or be nice and help you out.

Which would you rather?

feader
Bear Rating Master
Bear Rating Master
Posts: 160
Joined: 26 Dec 2012, 20:03

Re: [git] Mobile site not working?

Postby feader » 24 Mar 2013, 21:52

On my tablet, the standard look works pretty well. TTRSS wanted to take me to /mobile, so I had to remove the lines 34-42 in index.php. Since there are well working alternatives for phones: Will the whole "mobile check" thing be removed in future releases?

UncleAndy
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 24 Mar 2013, 22:51

Re: [git] Mobile site not working?

Postby UncleAndy » 24 Mar 2013, 23:05

It is reason for keep on old version. :(
Very bad idea - remove mobile version from main distro.

lyallp
Bear Rating Trainee
Bear Rating Trainee
Posts: 31
Joined: 20 Mar 2013, 09:20

Re: [git] Mobile site not working?

Postby lyallp » 26 Mar 2013, 15:21

I was quite impressed by a brief look at the mobile version on my iPhone with 1.7.4. I did not use it, but it was nice to know something was there, should I want to peruse my feeds on my iPhone.

I was quite suprised to find the mobile ability was gone in 1.7.5, even more so that it was not only gone but broken.

I am unsure as to why this was removed, particularly since I can't seem to find an obvious app in iTunes and the change log indicated that apps were the way to go.

shabble
Bear Rating Trainee
Bear Rating Trainee
Posts: 33
Joined: 18 Mar 2013, 23:40

Re: [git] Mobile site not working?

Postby shabble » 26 Mar 2013, 16:02

lyallp wrote:I am unsure as to why this was removed,

I get the impression that the codebase used for the mobile version was (3rd party and) outdated.

A quick alternative I used was
  • install ttrs-mobile (described here, download from here ('zip' link top left) ) - it could probably even go in your now-empty mobile directory.
  • Enabled API for my user
  • went to new URL (probably not be needed if you stuff it in the mobile directory)

Found it relatively painless myself, but I think some above may have had problems...?

xtaz
Bear Rating Master
Bear Rating Master
Posts: 174
Joined: 24 Dec 2009, 16:48

Re: [git] Mobile site not working?

Postby xtaz » 26 Mar 2013, 16:07

Change-logs are there for a reason: http://tt-rss.org/redmine/versions/87

Remove deprecated mobile/ in favor of mobile client by Matthieu Boinet


In other words it's specifically telling you to use the ttrss-mobile that you just linked to.

shabble
Bear Rating Trainee
Bear Rating Trainee
Posts: 33
Joined: 18 Mar 2013, 23:40

Re: [git] Mobile site not working?

Postby shabble » 26 Mar 2013, 16:20

xtaz wrote:Change-logs are there for a reason: http://tt-rss.org/redmine/versions/87

Remove deprecated mobile/ in favor of mobile client by Matthieu Boinet


In other words it's specifically telling you to use the ttrss-mobile that you just linked to.


You presume, of course, that when I started this thread that I was upgrading from 1.7.4 to 1.7.5, when the subject of the whole thread indicates quite the opposite.

Thank you for your concern however.

User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: [git] Mobile site not working?

Postby blainemono » 26 Mar 2013, 16:39

methinks that lady dost presumst too much

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [git] Mobile site not working?

Postby fox » 26 Mar 2013, 16:41

I don't want to be a bother or anything but ignoring both commit messages and release notes while following trunk is a sure way to hilarity town.

User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: [git] Mobile site not working?

Postby blainemono » 26 Mar 2013, 16:42

nah, I'm doing it and I'm ok

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [git] Mobile site not working?

Postby fox » 26 Mar 2013, 16:45

That's because you're a special boy. Not everyone is.

miqrogroove
Bear Rating Trainee
Bear Rating Trainee
Posts: 39
Joined: 20 Mar 2013, 02:08

Re: [git] Mobile site not working?

Postby miqrogroove » 26 Mar 2013, 16:46

In case anyone cares, I'm staying at 1.7.4 so that I can use Opera Mini 4.4, which is the latest browser version offered for my phone.

shabble
Bear Rating Trainee
Bear Rating Trainee
Posts: 33
Joined: 18 Mar 2013, 23:40

Re: [git] Mobile site not working?

Postby shabble » 26 Mar 2013, 16:47

fox wrote:.. but ignoring [...] commit messages ...


I know - that one was my fault. Or rather I skipped over it without realising the impact, and promptly forgot about it.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: [git] Mobile site not working?

Postby fox » 26 Mar 2013, 16:47

It would be quite easy to dig out mobile/ and convert it into a plugin or something for people who can't let go.


Return to “Support”

Who is online

Users browsing this forum: Google [Bot] and 9 guests