Session failed to validate (incorrect IP)

Support requests, bug reports, etc. go here. Dedicated servers / VDS hosting only
antiKk
Bear Rating Trainee
Bear Rating Trainee
Posts: 9
Joined: 26 Mar 2013, 03:33

Session failed to validate (incorrect IP)

Postby antiKk » 26 Apr 2013, 08:54

I'm running trunk currently and since switching from 1.7.8 I get logged out often.
It brings me back to the login screen and shows "Session failed to validate (incorrect IP)".

I use tt-rss at home and at work.
At home I do not have the issues.

I have tried different browsers and tried clearing cache etc..

tt-rss prefs > system > error log, doesn't seem to show anything.

Any suggestions?

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Session failed to validate (incorrect IP)

Postby fox » 26 Apr 2013, 11:54

Suggestion: try reading the error message.

antiKk
Bear Rating Trainee
Bear Rating Trainee
Posts: 9
Joined: 26 Mar 2013, 03:33

Re: Session failed to validate (incorrect IP)

Postby antiKk » 26 Apr 2013, 13:09

That I have done.
Can you tell me which IP it thinks is invalid?
Server IP, Client IP?

jakob42
Bear Rating Trainee
Bear Rating Trainee
Posts: 15
Joined: 20 Mar 2013, 16:43

Re: Session failed to validate (incorrect IP)

Postby jakob42 » 26 Apr 2013, 13:40

I guess your clients IP has changed and the session is bound to that.

dang
Bear Rating Trainee
Bear Rating Trainee
Posts: 14
Joined: 19 Mar 2013, 22:06

Re: Session failed to validate (incorrect IP)

Postby dang » 26 Apr 2013, 16:29

I get this whenever I move my laptop, so whenever it's IP changes. Just log in again.

jdelamater99
Bear Rating Master
Bear Rating Master
Posts: 109
Joined: 11 Apr 2013, 17:45

Re: Session failed to validate (incorrect IP)

Postby jdelamater99 » 26 Apr 2013, 16:49

antiKk wrote:That I have done.
Can you tell me which IP it thinks is invalid?
Server IP, Client IP?


Server IP probably doesn't change often. Most likely never changes. The session is tied to the client IP. Just log in again to initiate a new session with the current IP.

lotrfan
Bear Rating Disaster
Bear Rating Disaster
Posts: 73
Joined: 18 Mar 2013, 04:42

Re: Session failed to validate (incorrect IP)

Postby lotrfan » 27 Apr 2013, 00:06

Also see the 'SESSION_CHECK_ADDRESS' setting in config.php. By default, it checks the first three octets of the (client) IP when validating a session.

aelg305
Bear Rating Trainee
Bear Rating Trainee
Posts: 4
Joined: 02 Apr 2013, 17:05

Re: Session failed to validate (incorrect IP)

Postby aelg305 » 27 Apr 2013, 00:50

By default, it checks the first three octets of the (client) IP when validating a session


options:
-Try 2 instead of three
-if you are using a laptop, assign a static IP (not recommended) or get your mac and have the router always assign an specific IP to your TT-rss reading laptop! (most of the time when you resume a computer the ip may be renew as well)
-just log in and ignore it!

jakob42
Bear Rating Trainee
Bear Rating Trainee
Posts: 15
Joined: 20 Mar 2013, 16:43

Re: Session failed to validate (incorrect IP)

Postby jakob42 » 27 Apr 2013, 11:19

aelg305 wrote:-if you are using a laptop, assign a static IP (not recommended) or get your mac and have the router always assign an specific IP to your TT-rss reading laptop! (most of the time when you resume a computer the ip may be renew as well)

That only works if you have your ttrss installation locally available. If you have it on a server outside of your network your local IP should be meaningless. (Unless you got a small subnet from your provider and don't need to NAT, but I doubt that.)

antiKk
Bear Rating Trainee
Bear Rating Trainee
Posts: 9
Joined: 26 Mar 2013, 03:33

Re: Session failed to validate (incorrect IP)

Postby antiKk » 27 Apr 2013, 13:07

Thanks for the replies everyone.

I'm pretty sure I know what it is now that I think about it.

I'm trialling using multiple gateways at work (each connects me out via a different ISP).
I could have been getting dropouts with primary and defaulting to the secondary.

This would give me a distinctly different WAN IP without me realising I was getting disconnected.

Mirar
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 12 Jun 2013, 01:09

Re: Session failed to validate (incorrect IP)

Postby Mirar » 12 Jun 2013, 01:12

I'm not sure if I'm beating a dead horse here, but is there any way of skipping the IP part of the session so I can keep being logged in even though I switch IP? (I'm not particularly worried about that part of the security.) It's rather annoying if you're mobile and something you don't have control over keeps switching your IP number. To have that feature user-toggleable would be awesome.

User avatar
fox
^ me reading your posts ^
Posts: 6318
Joined: 27 Aug 2005, 22:53
Location: Saint-Petersburg, Russia
Contact:

Re: Session failed to validate (incorrect IP)

Postby fox » 12 Jun 2013, 09:41

Try reading through config.php.

Mirar
Bear Rating Trainee
Bear Rating Trainee
Posts: 2
Joined: 12 Jun 2013, 01:09

Re: Session failed to validate (incorrect IP)

Postby Mirar » 12 Jun 2013, 10:44

Code: Select all

        define('SESSION_CHECK_ADDRESS', 0);                                     
        // Check client IP address when validating session:                     
        // 0 - disable checking                                                 
        // 1 - check first 3 octets of an address (recommended)                 
        // 2 - check first 2 octets of an address                               
        // 3 - check entire address                                             


Excellent, thanks.

jannson48
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 03 May 2014, 09:33

Re: Session failed to validate (incorrect IP)

Postby jannson48 » 03 May 2014, 10:04

I'm running TT-RSS on a Synology NAS on my home network and was getting this error as well. Running "netstat" on the NAS showed that it was picking up my client address in IPv6 format, even though I'd connected using the IPv4 address of the NAS.

Code: Select all

tcp        0      0 ::ffff:192.168.1.5%18:80 ::ffff:192.168.1.14%3203635604:61628 ESTABLISHED


Disabling SESSION_CHECK_ADDRESS in config.php stopped the error messages.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 12 guests