Error in update.php & update_daemon2.php CRON

roman_rutov
Inadequate Idiots
Posts: 4
Joined: 02 Jul 2013, 10:10

Error in update.php & update_daemon2.php CRON

Postby roman_rutov » 02 Jul 2013, 10:55

Hi. I trying to configure automatic update with update.php.

update.php returns an error: "Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/a/admin25/reader.adminsk.ru/public_html/update.php on line 327".

"T_PAAMAYIM_NEKUDOTAYIM" - is a "::" symbols on line 327:
Image

When i delete one of ":", i see another error message: "Parse error: syntax error, unexpected ':' in /home/a/admin25/reader.adminsk.ru/public_html/update.php on line 327"

PHP version on my hosting i can change manually from 4.4 to 5.4, but update is not working with any version i select.
Image

Please help.

User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Error in update.php & update_daemon2.php CRON

Postby sleeper_service » 02 Jul 2013, 11:27


User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Error in update.php & update_daemon2.php CRON

Postby blainemono » 02 Jul 2013, 11:39


roman_rutov
Inadequate Idiots
Posts: 4
Joined: 02 Jul 2013, 10:10

Re: Error in update.php & update_daemon2.php CRON

Postby roman_rutov » 02 Jul 2013, 12:34

Search returns only 4 results.

So, i put the strings
php_value magic_quotes_gpc Off
php_value magic_quotes_runtime Off
php_value magic_quotes_sybase Off
..in .htaccess file. it did not help.

I change a PHP version to 5.3 in hosting options - it did not help.

Or... "Too bad. Contact your hosting support. Running tt-rss on shared hosting of any kind is NOT SUPPORTED. Do not file bugs about shared hosting restrictions, they will be closed."???

User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Error in update.php & update_daemon2.php CRON

Postby blainemono » 02 Jul 2013, 12:57


roman_rutov
Inadequate Idiots
Posts: 4
Joined: 02 Jul 2013, 10:10

Re: Error in update.php & update_daemon2.php CRON

Postby roman_rutov » 02 Jul 2013, 17:57

What then, is it possible to wait for help from the speaking anus "of Eternity"?

1. My PHP version is 5.3.22 (i check this, when load to root directory of tt-RSS this file: "<?php echo phpversion() ?>")
2. I put the strings "php_value ... Off" in the .htaccess file in the same directory, as for the update.php file.

What else, smart guy?

craywolf
Mr. Awesome
Posts: 97
Joined: 19 Mar 2013, 18:07

Re: Error in update.php & update_daemon2.php CRON

Postby craywolf » 02 Jul 2013, 17:59

Last edited by craywolf on 02 Jul 2013, 18:36, edited 1 time in total.

AngryChris
Bear Rating Master
Bear Rating Master
Posts: 135
Joined: 08 Apr 2013, 02:42

Re: Error in update.php & update_daemon2.php CRON

Postby AngryChris » 02 Jul 2013, 18:20


User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Error in update.php & update_daemon2.php CRON

Postby blainemono » 02 Jul 2013, 18:22


Orson74
Bear Rating Trainee
Bear Rating Trainee
Posts: 1
Joined: 02 Jul 2013, 19:03

Re: Error in update.php & update_daemon2.php CRON

Postby Orson74 » 02 Jul 2013, 19:05

Same Problem here.

My Problem with my NAS is, that the php-binary is older.

php -v show PHP 5.2.17

and phpversion() show 5.3.14

that's my problem.

User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Error in update.php & update_daemon2.php CRON

Postby blainemono » 02 Jul 2013, 19:18


User avatar
sleeper_service
Bear Rating Overlord
Bear Rating Overlord
Posts: 884
Joined: 30 Mar 2013, 23:50
Location: Dallas, Texas

Re: Error in update.php & update_daemon2.php CRON

Postby sleeper_service » 02 Jul 2013, 21:58


roman_rutov
Inadequate Idiots
Posts: 4
Joined: 02 Jul 2013, 10:10

Re: Error in update.php & update_daemon2.php CRON

Postby roman_rutov » 03 Jul 2013, 10:19

you two are inadequate idiots. what the point of writing a web product that may NOT work with shared hosting? For local use i have FeedDemon. Maybe instead went into hysterics, you should just take your hands out of your asses and fix this error? or, eventually, write in LARGE LETTERS on the homepage and download page of the product, that they can NOT normally use with shared hosting. I killed two fucking days to your crappy script. if I had been warned once - I would have migrated to the feedly.

User avatar
blainemono
Gaping Anus of Eternity
Gaping Anus of Eternity
Posts: 246
Joined: 05 Jun 2009, 18:13

Re: Error in update.php & update_daemon2.php CRON

Postby blainemono » 03 Jul 2013, 10:36


User avatar
swa
Bear Rating Trainee
Bear Rating Trainee
Posts: 6
Joined: 27 May 2013, 23:16

Re: Error in update.php & update_daemon2.php CRON

Postby swa » 03 Jul 2013, 10:39

Open your eyes, buddy.
Image


Return to “Comedy bistro”

Who is online

Users browsing this forum: No registered users and 0 guests